warning and severe error about same edge on two surfaces and zone not being fully enclosed in OpenStudio

asked 2018-08-06 11:50:01 -0600

updated 2018-08-06 11:54:36 -0600

Hi :)

After running in OpenStudio app I had a lot of errors like this one

** Severe ** For zone: THERMAL ZONE: CORRIDOR S1 it is not possible to calculate the volume from the surrounding surfaces so either provide the volume value or define all the surfaces to fully enclose the zone.

** Warning ** CalculateZoneVolume: The Zone="THERMAL ZONE: CORRIDOR S1" is not fully enclosed. To be fully enclosed, each edge of a surface must also be an edge on one other surface.

** ~~~ ** The zone volume was not calculated and an error exists.

** ~~~ ** The surface "SURFACE 1367" has an edge that is either not an edge on another surface or is an edge on three or more surfaces

** ~~~ ** The surface "SURFACE 1431" has an edge that is either not an edge on another surface or is an edge on three or more surfaces ............. etc (same thing for other zones)

For the severe error I checked and all the surfaces are fully enclosing the zone,and @AaronBoranian

says here that it is possible to enter manually the volume of each thermal zone using the openStudio inspector in Sketchup, but the problem is that I am modelling a residential building of 11 flats and I have a lot of thermal zones, it won't be practical to manually calculate the volume of each one and enter it.

So if anyone have an idea about how to fix this, it would be really great ?

And for the warning, I didn't know how to fix the problem with edges. Maybe if I find a solution for that, I won't have the previous error as well because apparently the severe error and the warning are related according to @JasonGlazer while responding to this post

Can anyone please explain to me how to also fix the edge problem ?

Thanks :) Greetings

edit retag flag offensive close merge delete

Comments

1

did you see my comment here?: https://unmethours.com/question/33262...

You most likely made an error in drawing the zones and have a line that isn't straight, or two lines that aren't exactly parallel, creating a small sliver of surface between zones that is causing your error. You can check for this by reporting out surfaces and seeing if any have very small area.

mdahlhausen gravatar imagemdahlhausen ( 2018-08-06 14:16:22 -0600 )edit

Hi @mdahlhausen , thanks for your comment, I just answered here. Concerning this, I don't how is it possible to have as you said : 'a line that isn't straight, or two lines that aren't exactly parallel' because I just used 'creating spaces from diagram' OS tool. But anyways I already removed manually all the small slivers of surface between zones and checked each space in the building, but I still have the errors above.

Raghda Derbel gravatar imageRaghda Derbel ( 2018-08-07 03:17:25 -0600 )edit

Do you know how to make a surface edge common to another surface, as requested ? Thanks

Raghda Derbel gravatar imageRaghda Derbel ( 2018-08-07 03:19:58 -0600 )edit
1

The spaces from diagram tool will introduce those errors if the underlying floorprint isn't aligned perfectly. Also, if you remove those small slivers then you will introduce unenclosed volumes and still have surface mismatches in the model. To make sure the edges are common, delete the edge, and then re-draw it snapping to both vertices.

mdahlhausen gravatar imagemdahlhausen ( 2018-08-07 10:35:47 -0600 )edit

All right! Thanks :)

Raghda Derbel gravatar imageRaghda Derbel ( 2018-08-07 10:44:37 -0600 )edit