Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
4

Surface warnings

asked 2017-12-17 18:21:43 -0600

baum gravatar image

I am currently dealing with a large number of warnings in the form of,

The surface "SURFACE 825" has an edge that is either not an edge on another surface or is an edge on three or more surfaces: * ~~~ * Vertex start { 3.6652, -10.7695, 3.8608} * ~~~ * Vertex end { 3.8842, -10.6438, 3.8608}

Would anyone have any guidance on how I could correct this warning?

Thank you, Steven

edit retag flag offensive close merge delete

Comments

@baum, can you give some history of the file. What version of OpenStudio are you using, did you create geometry from scratch in OpenStudio or was there a source gbXML or DXF file that was imported?

David Goldwasser gravatar imageDavid Goldwasser ( 2017-12-18 11:13:40 -0600 )edit

I am using 2.3.0 currently. The geometry was created using sketchup with the openstudio plugin.

baum gravatar imagebaum ( 2017-12-18 20:44:41 -0600 )edit

@David Goldwasser if it helps I can send link to my model before and after I corrected it.

Avi gravatar imageAvi ( 2017-12-19 03:45:47 -0600 )edit

@Avi, that would be great.

David Goldwasser gravatar imageDavid Goldwasser ( 2017-12-19 09:49:36 -0600 )edit

@David Goldwasser I sent it. Did you get it?

Avi gravatar imageAvi ( 2017-12-20 14:54:07 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2017-12-18 08:03:13 -0600

EnergyPlus now uses an algorithm that detects if each zone volume is fully enclosed (think leak proof). The algorithm checks to see if each edge of each surface is used touched by just one other edge of another surface. If this does not occur the warning message that you saw will be shown. I would look at that surface and that edge in particular and check if touches another surface edge. It might make sense to visualize the model in Sketchup using Euclid or OpenStudio. It is very likely that the warning message does show a problem with the zone not being fully enclosed. If that is intentional, you can ignore the warning. If the zone is fully enclosed but the way the edges are arranged is complicated you should also feel free to ignore the warning.

edit flag offensive delete link more

Comments

Along these same lines, if the zone is fully enclosed but the way the edges are arranged is complicated, double check what the zone volume is in the outputs. When this new algorithm calculates volumes, these types of not fully enclosed to the algorithm zones sometimes size as 10-20x the actual zone volume. You should be able to hard-code the volume in the thermal zone object.

M_Shannon gravatar imageM_Shannon ( 2017-12-19 09:40:24 -0600 )edit

@M_Shannon, I would like to see an example of this 10-20x problem you are seeing. Could you email me the file? jglazer at gard dot com.

JasonGlazer gravatar imageJasonGlazer ( 2017-12-19 09:47:03 -0600 )edit

@M_Shannon, how can you hard-code the volume? I don't see that option in thermal zone object. I'm using OpenStudio 2.5.0.

anchapin gravatar imageanchapin ( 2018-07-13 14:48:44 -0600 )edit
1

answered 2017-12-17 23:45:05 -0600

Avi gravatar image

updated 2017-12-17 23:47:50 -0600

I had the same problem that might be an issue with SketchUp or OS. What I found out in my case was that a Stairwell I modeled as a single space was not oriented in the same direction as the rest of the model. That led into very small differences in coordinates of adjacent walls, in order of less than one millimeter, due to the rotational translation needed between space origin and model origin. I ended up rotating the stairwell space origin in the direction of the rest of the model, then I redrew the stairwell and problem was fixed.

So I think that you should look for something similar.

edit flag offensive delete link more
0

answered 2018-05-08 21:54:54 -0600

wollz gravatar image

I have the same problem, but I can not find the line that E + warns, even opening the file in SU. Everything looks ok. Anyone with the same problem?

The warning: * Warning * CalculateZoneVolume: The Zone="94" is not fully enclosed. To be fully enclosed, each edge of a surface must also be an edge on one other surface. * ~~~ * The zone volume was calculated using the floor area times ceiling height method where the floor and ceiling are the same except for the z-coordinates. * ~~~ * The surface "94_CEILING_1_0_0" has an edge that is either not an edge on another surface or is an edge on three or more surfaces: * ~~~ * Vertex start { 0.2121, -0.4419, 3.3000} * ~~~ * Vertex end { -1.3081, 1.0783, 3.3000} * ~~~ * The surface "94_CEILING_1_2_1" has an edge that is either not an edge on another surface or is an edge on three or more surfaces: * ~~~ * Vertex start { 2.1567, -2.3865, 3.3000} * ~~~ * Vertex end { 0.2121, -0.4419, 3.3000}

The surface IDF:

BuildingSurface:Detailed, 94_Ceiling_1_0_0, !- Name Ceiling, !- Surface Type 3, !- Construction Name 94, !- Zone Name Surface, !- Outside Boundary Condition 228_Floor_0_0_10061, !- Outside Boundary Condition Object NoSun, !- Sun Exposure NoWind, !- Wind Exposure 0, !- View Factor to Ground , !- Number of Vertices 2.6625, !- Vertex 1 X-coordinate {m} -1.6875, !- Vertex 1 Y-coordinate {m} 3.3, !- Vertex 1 Z-coordinate {m} 2.6625, !- Vertex 2 X-coordinate {m} 0.4625, !- Vertex 2 Y-coordinate {m} 3.3, !- Vertex 2 Z-coordinate {m} 0.1625, !- Vertex 3 X-coordinate {m} 0.4625, !- Vertex 3 Y-coordinate {m} 3.3, !- Vertex 3 Z-coordinate {m} 0.1625, !- Vertex 4 X-coordinate {m} -1.6875, !- Vertex 4 Y-coordinate {m} 3.3; !- Vertex 4 Z-coordinate {m}

BuildingSurface:Detailed, 94_Ceiling_1_2_1, !- Name Ceiling, !- Surface Type 3, !- Construction Name 94, !- Zone Name Surface, !- Outside Boundary Condition 265_Floor_0_0_10042, !- Outside Boundary Condition Object NoSun, !- Sun Exposure NoWind, !- Wind Exposure 0, !- View Factor to Ground , !- Number of Vertices 0.3375, !- Vertex 1 X-coordinate {m} 0.4625, !- Vertex 1 Y-coordinate {m} 3.3, !- Vertex 1 Z-coordinate {m} 0.3375, !- Vertex 2 X-coordinate {m} 3.2125, !- Vertex 2 Y-coordinate {m} 3.3, !- Vertex 2 Z-coordinate {m} 0.1625, !- Vertex 3 X-coordinate {m} 3.2125, !- Vertex 3 Y-coordinate {m} 3.3, !- Vertex 3 Z-coordinate {m} 0.1625, !- Vertex 4 X-coordinate {m} 0.4625, !- Vertex 4 Y-coordinate {m} 3.3; !- Vertex 4 Z-coordinate {m}

edit flag offensive delete link more

Comments

@wollz please open new question

Avi gravatar imageAvi ( 2018-05-08 23:50:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

3 followers

Stats

Asked: 2017-12-17 18:21:43 -0600

Seen: 349 times

Last updated: May 08