Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

OS Error:''For zone: it is not possible to calculate the volume from the surrounding surfaces so either provide the volume value or define all the surfaces to fully enclose the zone.''

asked 2017-12-14 09:24:32 -0500

Ifigeneia's avatar

updated 2017-12-14 11:10:24 -0500

I get the error for the majority of the rooms of my model! I have tried to solve the problem through sketchup (I checked the surfaces, and I redraw some of them to ensure that they fully enclose the zone) but I got back the same error. So, I thought that the easiest way is to provide the volume value, but I can't find in which field I can do it. Has anyone experienced it before? Do you know where can I provide the value of the volume? Thamk you in advance for your help and time!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-12-14 11:49:41 -0500

It does not appear that you can directly set thermal zone volume within the OpenStudio application. You could try directly setting thermal zone volume in SketchUp using the OpenStudio extension. Below is a screen shot of using the OpenStudio Inspector, selecting a thermal zone, and then where to potentially set volume.

image description

Setting thermal zone volume in OpenStudio Inspector

If that doesn't work, then I would recommend that you carefully review your geometry in SketchUp, using the "Hide Rest of Model" rendering option while editing the geometry.

image description

"Hide Rest of Model" option in OpenStudio Rendering Toolbar

edit flag offensive delete link more


You may also want to look at this post where error was about negative calculated volume.

For your geometry in particular make sure you don't have floor defined as a ceiling, and ceiling as a floor. Can also use render by face normal to look for reversed surface orientation. This isn't on the render menu bar, but is under "Extensions/OpenStudio/Rendering". From exterior everything should be white.

David Goldwasser's avatar David Goldwasser  ( 2017-12-14 12:03:34 -0500 )edit

Thanks a lot for the answer/comment! I insert the values manually through OpenStudio extension as shown in the image and I dont get the errors any more! The render by face normal command was also really useful!

Ifigeneia's avatar Ifigeneia  ( 2017-12-15 03:29:09 -0500 )edit

For anyone interested in changing the volumes more quickly, you can also manually type in the volume into the *.osm file through a text editor. I found this method to be much faster. However, it was easier because I previously defined specific zone names. Thank you for the information, I was able to correct the same error.

JustinShultz's avatar JustinShultz  ( 2018-05-30 08:57:50 -0500 )edit

@Aaron Boranian I tried to enter manually the volume for the thermal zone in the inspector, but the problem is that not all of them have the same volume which will affect the results. For example I have a thermal zone for KITCHEN but not all kitchens in the building have the same size/volume, and when I enter the volume of one of them as shown above, the other kitchens will have the same default value.

Raghda Derbel's avatar Raghda Derbel  ( 2018-08-07 07:39:14 -0500 )edit

@Raghda Derbel, you will need to define a new thermal zone for each kitchen.

JustinShultz's avatar JustinShultz  ( 2018-08-07 08:02:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops


Question Tools

1 follower


Asked: 2017-12-14 09:24:32 -0500

Seen: 1,172 times

Last updated: Dec 14 '17