Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

Problems regarding schedule configuration

asked 2018-04-25 21:03:42 -0500

rogerkille gravatar image

updated 2018-04-26 07:49:39 -0500

Dear community,

I am currently trying to configure a schedule consisting of around 8,500 lines. Due to this size, I started to use the Excel to IDF Macro (see https://github.com/jmarrec/Useful-Exc...) to copy paste our schedule which I have created in Excel.

Our schedule functions via a 'fraction' logic and unfortunately, EnergyPlus does not accept our given fraction values that are included. This becomes already obvious when EnergyPlus does not transform our input 0,02 into .02 as usual.

In the error file it tells me that the schedule has 'missing days in its schedule pointers'. Due to this error the modelling cannot even be finished and no data is included in the output files.

When I start to type in my schedule individually, rather than copying it in via the Excel Macro, it all works perfectly fine. Due to the 8,500 lines I am not able to type the whole thing individually.

I have attached a picture of the error file and the IDF Input:

IDF

eplusout.err

My analysis is going towards calculating the energy consumption of a building, hence quite a simple analysis.

Thank you very much for your help and best wishes,

Roger

edit retag flag offensive close merge delete

Comments

Try using the Schedule:File object instead. There are several posts on the forum about how to implement that, as well as a BCL measure for OpenStudio models. See https://unmethours.com/question/31122/too-many-fields-for-objectschedule-compact/

mdahlhausen gravatar imagemdahlhausen ( 2018-04-26 18:00:15 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2018-04-26 03:10:53 -0500

updated 2018-04-26 03:11:38 -0500

I'm the author of the Excel to IDF macro you linked to.

What you're getting is simply a locale issue: your decimal separator is the comma , while the macro assumes you are using the dot ..

EnergyPlus IDF format uses the , as a field separator, so it's getting really confused here.

The easiest fix is probably is to temporarily change the decimal separator, see Microsoft Help, though I think selecting all your numeric cells (your entire column here) and searching for , and replacing with . should work too.

edit flag offensive delete link more

Comments

Hi Julien,

you can ignore my previous post from an hour ago. I got it now :-).

Our schedule didnt cover the whole year. So, as we dont yet have the data for the rest of the year, I changed the last "through" filed to "through: 12/31", so that the last pattern is now repeated for the rest of the year.

rogerkille gravatar imagerogerkille ( 2018-04-26 05:09:47 -0500 )edit

Glad you got it working. For the record, there is now a Schedule:File object in E+ that allows you to load data from a CSV file directly. You'll still need 8760 hours of the year to avoid a warning. The only "problem" I have with this object is that it's unclear how to properly define the Winter/Summer Design day behavior.

Julien Marrec gravatar imageJulien Marrec ( 2018-04-26 14:26:41 -0500 )edit

Thanks for the info, without the Macro we would probably have used a CSV file. We also get that "problem" with Winter/Summer Design day behaviour - though it is only considered as a error and thus doesn't really affect the results :-).

rogerkille gravatar imagerogerkille ( 2018-05-03 11:21:42 -0500 )edit

Related issue on OpenStudio's github: https://github.com/NREL/OpenStudio/is...

Julien Marrec gravatar imageJulien Marrec ( 2018-05-04 01:57:52 -0500 )edit
1

answered 2018-04-26 03:48:19 -0500

rogerkille gravatar image

updated 2018-04-26 03:54:06 -0500

Hi Julien,

Thanks very much for the quick reply (and also the Excel Macro, without it we wouldn't be able to do the analysis!).

Yesterday we already had the data in Excel with a decimal point and ran the Macro on it which didn't give us the data in the IDF Editor in the correct format.

I tried the following: 1) Running the Macro on the Excel Data with a decimal point 2) Running the Macro on the Excel Data with a decimal point while also changing system seperator in Excel Settings 3) Running the Macro on the Excel Data with a decimal point and formatting the Number Format to i) General; ii) Number and also tried iii) Text 4) Running the Macro on the Excel Data with a comma

I have attached a screenshot of the Excel and a screenshot of the IDF Editor. In the IDF Editor it give us the number format either in "," or it separates the 0.5 into two rows (Row 1: 0 and Row 2: 5). See screenshot.C:\fakepath\IDF Editor.png C:\fakepath\Excel Screenshot.png We arer really clueless.. have you got any other ideas?

We would highly appreciate any support :-).

Best regards, Roger

edit flag offensive delete link more

Comments

Please edit your question or put this in a comment, rather than putting this as an answer.

mdahlhausen gravatar imagemdahlhausen ( 2018-04-26 17:59:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-04-25 21:03:42 -0500

Seen: 62 times

Last updated: Apr 26 '18