Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
6

Too many fields for object:Schedule Compact

asked 2018-04-25 20:50:32 -0600

adireddi gravatar image

updated 2018-04-26 10:36:38 -0600

Hello,

I am getting an error "Too many fields for object:Schedule Compact" when trying to open a idf file that was exported using OS v2.5.0 . I used a measure (courtesy of @Lyle K , for sharing the measure) to bring in 8760 hourly data and assigned it to load profile plant object.

One of the discussion threads suggested that adding more lines to "Energy+idd file" would help resolve the issue. However, I didn't quite understand what piece of text to add to the idd file. Any input on this would be helpful.

My goal is to ultimately open the file using IDF editor and attempt to add more customization on the plant loop.

Attached is the idf file.

Thank you, -Aditya

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
5

answered 2018-04-26 10:56:02 -0600

It does sound like there are insufficient fields in the IDD for IDF Editor to properly read it. What you'll need to do is find the "Energy+.idd" file in your E+ installation and open it in a text editor. Be careful if you are on Windows, I'm not sure Notepad will work for this. Search for the string "Schedule:Compact", and not that there's a line in there that says:

\extensible:1 - repeat last field, remembering to remove ; from "inner" fields.

This is telling you that the object is extensible one field at a time. Other objects have to be extended in chunks of multiple fields. If you scroll down to the end of the object, you should see a line like this:

A4488,A4489,A4490,A4491,A4492,A4493,A4494,A4495,A4496,A4497,A4498,A4499,A4500; \note fields as indicated

What you're going to need to is to delete that ';' and add a A4501 etc. after this line (and make sure you end it all with a ';'). You'll probably need to add a lot of fields.

You might want to consider using Schedule:File instead of Schedule:Compact. Schedule:File isn't presently supported by OpenStudio, but since you can edit those files with just about any spreadsheet program it might be worth your while to translate your schedules into that format.

edit flag offensive delete link more

Comments

@Jason DeGraw - Thank you for the prompt response. Yes, that's a lot of fields to add. I will explore the option of adding "Schedule:File" and calling the .csv file using the idf editor.

adireddi gravatar imageadireddi ( 2018-04-26 14:10:12 -0600 )edit

Obviously a scripting program would help you to generate the remaining fields to be copy pasted into the E+.idd (don't do it by hand). Here's a python one-liner: ",".join(['A{:.0f}'.format(i) for i in range(4501,9000)]) + ";" and the output it generates is here (you can copy that)

Julien Marrec gravatar imageJulien Marrec ( 2018-04-26 14:31:17 -0600 )edit

Thanks! Julien for the Python code and data points.

adireddi gravatar imageadireddi ( 2018-04-26 20:59:21 -0600 )edit
4

answered 2018-04-26 17:55:42 -0600

The Schedule:File is what you want to use for 8760 data. The BCL measure Add Interval Schedule From File will add a Schedule:File object to your OpenStudio model from a .csv file of values.

edit flag offensive delete link more

Comments

Thank you Matt, for pointing me towards the BCL measure. It worked!

adireddi gravatar imageadireddi ( 2018-04-26 21:01:45 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-04-25 20:50:32 -0600

Seen: 125 times

Last updated: Apr 26 '18