Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

Surface matching error in Sketchup

asked 2018-01-15 03:51:27 -0500

AadriaanW gravatar image

updated 2018-01-16 10:27:12 -0500

Im running into an error each time I am trying to model a building. This building has 12 floors and has a different floor plan for almost each floor. When trying to intersect + surface match the building it didnt match all the surfaces correctly. I've looked at similar issues on this forum: here and here and here but none of these options seemed to work.

image description

I have added a picture from an example design I made. I've set this up by placing the second floor layout type exactly 9 meters above the first one, and then using 'Create Spaces From Diagram' with 3 floors of 3 meters high each. This is the closest I've come so far to a good surface matching, but for some reason it still doesnt match all the surfaces properly.

With which approach do you think I could model my (complex) building in the most efficient way? Still use the floor plans of each? Or should I model the floor plan in the 'New Space' function and then extrude all the different floor area's?

edit retag flag offensive close merge delete

Comments

@AadriaanW could you post a link to your model?

Avi gravatar imageAvi ( 2018-01-15 04:50:59 -0500 )edit

Here is a link to the model i was working on: https://drive.google.com/drive/folder...

The problem is that I also run into this problem with new models I make just to try it out. So my suspicion is that its not just the model ive just sent you, but more of an Sketchup/Openstudio thing.

AadriaanW gravatar imageAadriaanW ( 2018-01-15 08:07:29 -0500 )edit

@AadriaanW in the model you sent there is only one Space. I guess you didn't want it to be that way. Am I right?

Avi gravatar imageAvi ( 2018-01-15 12:24:49 -0500 )edit

Correct, I do not want it that way. That model was just an experiment to figure out how this works. If you look at the picture above you see the error I kept running into with different versions of that model.

AadriaanW gravatar imageAadriaanW ( 2018-01-15 20:37:38 -0500 )edit

I've added the model of the building itself in this link: here Im just looking for the best way to model a building with a different floor plan for almost every floor. Please let me know what you can find!

AadriaanW gravatar imageAadriaanW ( 2018-01-16 01:04:38 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
4

answered 2018-08-31 10:58:47 -0500

akr gravatar image

Although you might have found a solution to this issue long ago, just wanted to leave my answer here for the benefit of others. I had lot of surface matching/intersection problems as well to the extent I may have to redraw a multi-story building. The surface matching tools through SketchUp always caused several errors. The workaround was to use the OpenStudio Measure "SurfaceMatching" through "Apply Measures Now" in OpenStudio interface to your model. This solved almost all the surface matching errors. Please note that this should be applied to the model without doing any surface matching/intersections through Sketchup/OpenStudio Plugin.

edit flag offensive delete link more
1

answered 2018-01-16 03:21:50 -0500

Avi gravatar image

I was able to reproduce the issue you described. You can work around it in the following manner.; First create the geometry from floorplan of the first identical stories. Than create new space on top of it and again create the upper stories from Floorplan. Now just intersect the entire model without matching. Now from the OS toolbar select the state which presents only the selected space. Then select the upper space in the lower part. You are wiil find that there is a missing ceiling surface. Using the pencil redrew the missing surfac. Now you can match the entire model and you are done.

edit flag offensive delete link more

Comments

I've think i've followed all your steps but still something went wrong. I took a smaller model of the one i was trying to make, since itll go a bit faster but I still have many surfaces which connect to the outside. Before you replied I made a new model, in which I used the Create Surfaces From Diagram function to build the model. All zones were created by extruding to the height of the next floor plan. This greatly improved the amount of surfaces that were detected, all though I did this before reading your post. Still many are outside. could this be OS settings or am i doing something wrong?

AadriaanW gravatar imageAadriaanW ( 2018-01-16 04:08:43 -0500 )edit

@AadriaanW Whenever you get outside conditions it is because after intersecting there is a missing surface on one of the sides. if you make sure that all missing surfaces are redrawn than matching them will yield good results.

Avi gravatar imageAvi ( 2018-01-16 05:54:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-01-15 03:51:27 -0500

Seen: 429 times

Last updated: Aug 31 '18