Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

This sub surface is the same as its base surface, it cannot be drawn.

asked 2017-11-03 04:20:02 -0600

Arghavan.A gravatar image

updated 2017-11-13 18:59:43 -0600

After importing gbXML from a Revit-based model through Openstudio plugin in SketchUp, I encountered this error: "This sub surface is the same as its base surface, it cannot be drawn." I can see that a part of my floor is not imported which included the thermal insulation. However, I still don't understand what does this error mean? and how it will be fixed?

Additionally, windows are not imported correctly!? They seem light brown (as if walls) and just the perimeter is visible by lines. I didn't receive any error about it! What should I do?

Link to the Revit model and gbXML: Link to the Revit model and gbXML

image description

Version Revit: 2018 Version SketchUp: Make 2017 Version OpenStudio: 2.3

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-11-05 02:10:39 -0600

Avi gravatar image

updated 2017-11-15 00:19:51 -0600

As simple as it says there is a surface (probably a floor surface) which is fully covered by subsurface (usually windows or doors) so the subsurface can't be drawn. You can go on and try to delete the subsurface using OpenStudio. If you need directions with that please leave a comment.

About the windows, try to inspect them with the OpenStudio inspector window in SketchUP and let us know what kind of surface they were converted into. A picture might help as well.

First you would like to read that question. Especially look at the known issues linked at the bottom of the page.

For your sample building it is not too hard to correct the model here is what I did: Apparently there are many unnecessary lines and surfaces drown on the front wall you need to delete them all without deleting the front wall surface. Make sure that you delete the rectangles representing the windows by double clicking on them to select both the bounding edges and the surface itself. Now you will need to save and reopen the file. At that point new lines that weren't apparent before will show up on the front wall delete them all. Now click on the front wall and remember it's name as depicted in the OpenStudio inspector (Open it if it is not open). Select each of the two subsurfaces remaining in the OS inspector and then in the edit object side of the inspector change the missing surface name into the name of the front wall surface. Save and reopen and you are done.

I am not familiar with Revit but if I were you I would have try to change my model there ( maybe make less detailed windows) before importing to OS. Maybe someone more experienced with exporting from Revit can help here.

edit flag offensive delete link more

Comments

1

I will check the windows and comment later! thank you so much!

Arghavan.A gravatar imageArghavan.A ( 2017-11-06 08:06:58 -0600 )edit

@Avi Hi again. I made another model, but encountered the same problem! I don't understand why?!? I uploaded a photo and also provided a link for my Revit model and gbXML file.Can you please guide me?

Arghavan.A gravatar imageArghavan.A ( 2017-11-13 19:01:02 -0600 )edit
1

What settings for the export do you use? "Function parameter" works fine, also, don't use gbXML exported by GBS or Insigt - they look exactly as on the picture and the problem is the same - during triangulation of the surfaces walls created at the same places as windows. As the result windows are not imported to OS

Dinosaver gravatar imageDinosaver ( 2017-11-17 10:52:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-11-03 04:20:02 -0600

Seen: 60 times

Last updated: Nov 15