Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
4

Some surfaces are being counted twice in the surface area

asked 2017-07-28 10:17:29 -0600

atwoodmk gravatar image

updated 2017-07-31 09:18:19 -0600

I am having the same issue as I found here: link text

One of my spaces has the floor divided into 2 surfaces to reflect the geometry underneath. When I run my model through OpenStudio or EnergyPlus, I get the incorrect floor area for this space. Same with the Space Type Report. If I use the Sketchup tool Entity Info and I add up the area of the 2 surfaces, it is correct, so I know it's not a geometry problem. But I did find that if I double the floor area of one of the surfaces, I get the same surface area that OS and EP show which leads me to believe it is counting that surface twice. Another interesting part, if I erase the line separating the two surfaces, the Space Type Report shows the correct area now, and if I draw the lines back in, or intersect the surface with my model, the same surface is doubled again.

I tried going into the idf text for this model to see if the surface is repeating there. I can see there are only 2 floor surfaces as there should be and nothing repeats. I also tried to see if any of the issues on the linked page would be an issue, and they are not.

I've run this model multiple times and looked at the Errors EnergyPlus shows, and there is no warning that this is happening. I didn't even notice the area was wrong until I compared my model to a reference.

What can I do to stop the surface from being counted twice and get the correct floor area?

Thank you for your help.

Edit:

This is the space I'm having problems with and the two surfaces. The smaller one is the one that is repeating

image description

Here is the IDF text for the two floor surfaces:

image description

image description

Edit 2:

My surfaces are shown here as separate, but on the IDF file I'm still only getting 12 vertices.

image description

Also I don't know why the special characters are in the name. I didn't put them there.

edit retag flag offensive close merge delete

Comments

@atwoodmk can you update your question with screenshot or two. You should have enough Karma points to do that now. Maybe also include the OSM or IDF text for the two floor surfaces.

David Goldwasser gravatar imageDavid Goldwasser ( 2017-07-28 11:35:58 -0600 )edit

I've updated the post with some pictures, hope it makes it more clear.

atwoodmk gravatar imageatwoodmk ( 2017-07-28 11:50:50 -0600 )edit

@atwoodmk can you tell me how many vertices the OSM file has for that same surface? If it also has 12, then what happens if you close the OSM and re-open it, does it still look like the screenshot above (where dot pattern doesn't cover smaller rectangle), and do you get any warnings on opening the file.

If the OSM file shows 16 vertices and the IDF shows 12, there there is something odd going in, please send the file to OpenStudio@nrel.gov if that is the case and we can try and replicate it.

David Goldwasser gravatar imageDavid Goldwasser ( 2017-07-31 11:26:39 -0600 )edit

I checked the OSM file and I actually can't find either of the floor surfaces in the text. I can find other floors from other building stories, but those two aren't there at all. When I open and close the text file, the model still looks like the screenshot, and I do not get any warnings. I figured out I'm having this same issue on another floor as well. I calculated by hand how much surface area I should be getting from energyplus, and even when I do not include the original problem surface for the floor area, it's still off by 50m^2. I'll send an email to that address with my model. Thanks

atwoodmk gravatar imageatwoodmk ( 2017-07-31 14:31:35 -0600 )edit

I sent an email to the address in the above comment about a week ago and I still haven't heard back yet. Thanks for your help so far.

atwoodmk gravatar imageatwoodmk ( 2017-08-08 08:42:18 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2017-07-28 11:58:46 -0600

updated 2017-08-09 14:49:34 -0600

Thanks, the images and text help. First thing I notice is that the "C" shaped surface looks like it should have 16 vertices, but it only has 12. I bet if you select the "C" shaped surface so it has the dot pattern, that the dot pattern extends over the entire floor, including the area where the smaller rectangular surface is.

Not sure why but the rectangle is probably not exactly in plane with the "C" shaped surface. Select the rectangle, and the 3 edges that are not shared and delete them; then try to re-draw it making sure that you are snapping to the "C" shaped surface. If you need to create interceptions for surface matching, either manually draw in SketchUp, if just a few surfaces, or use the Surface Matching measure in the OpenStudio application. It has a checkbox for intersection.

Also, the special characters in the construction names is probably not a good idea, may come back and bite you later, but sounds like at least for now it has been running fine in EnergyPlus with those names.

Update:

@atwoodmk, I was able to look at your file, and do some testing with a new clean file, and was able to duplicate what you are seeing and come up with a work around. If you look at the image below.

  1. If you draw a "C" shape as an OpenStudio surface in the SketchUp Plugin it make a surface with 8 vertices
  2. If you draw lines or a rectangle to fill in part of the opening of the "C" it doesn't alter the main surface
  3. If you fill in the entire opening it removed 4 of the vertices from the main surface. (You may see a sub-surface vs. a surface but either way it isn't what you want.
  4. The best workaround for now is to split the main surface, then fill in the "C". (I tried to get sneaky and remove the new split lines after I filled the "C", but still messes things up.

image description

Some additional notes: The issue appears to be trying to create a surface that fits within the bounds of another surface. I believe this is just an issue with geometry drawn or saved in SketchUp, and it is not a limitation of the OpenStudio "Surface object". There are some symptoms you would see if this is has happened in your model. If this is only an issue on one of two spaces, then surface matching should fail. and if you look in the eplusout.err file you will see a warning like this " * Warning * GetSurfaceData: InterZone Surface Areas do not match as expected and might not satisfy conservation of energy:". If two adjacent spaces suffered the same issue you may not see any symptoms.

I tested this in SketchUp 2017 with OpenStudio 2.2.0 and in SketchUp 2016 with OpenStudio 1.14.0. We are developing a stand alone 2d geometry editor as an alternative to the SketchUp plugin and ... (more)

edit flag offensive delete link more

Comments

The surfaces were already separate, but I tried what you suggested anyway. I updated the post to show the surfaces. I'm still getting the same problem.

atwoodmk gravatar imageatwoodmk ( 2017-07-31 09:20:45 -0600 )edit

Thank you, cutting up the surface like that works perfectly.

atwoodmk gravatar imageatwoodmk ( 2017-08-10 08:54:45 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-07-28 09:44:31 -0600

Seen: 129 times

Last updated: Aug 09