Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question

Revision history [back]

Set Window to Wall Ratio in Sketchup fails

I'm modeling a building with OpenStudio that has a lot of glazing according to Appendix G, so for the baseline I need to reset the window to wall ratio to 0.4. Seems like a perfect application to leverage the User Script "Set Window to Wall Ratio".

The problem I'm getting is that it doesn't do anything on my model, even if I try on very simple zones like the following.

Example of one zone

One I select the outdoor surface and apply the measure, nothing changes:

Surface selected

One thing is that, if I create a new space in my model and put a cube in there, the "Set Window to Wall Ratio" user script works like a charm on this.

Can someone offer a clue as to why it doesn't work?

Set Window to Wall Ratio in Sketchup fails

I'm modeling a building with OpenStudio that has a lot of glazing according to Appendix G, so for the baseline I need to reset the window to wall ratio to 0.4. Seems like a perfect application to leverage the User Script "Set Window to Wall Ratio".

The problem I'm getting is that it doesn't do anything on my model, even if I try on very simple zones like the following.

Example of one zone

One I select the outdoor surface and apply the measure, nothing changes:

Surface selected

One thing is that, if I create a new space in my model and put a cube in there, the "Set Window to Wall Ratio" user script works like a charm on this.

Can someone offer a clue as to why it doesn't work?

Update: Here is the link to the problematic OSM File if someone can take a look

Set Window to Wall Ratio in Sketchup fails

I'm modeling a building with OpenStudio that has a lot of glazing according to Appendix G, so for the baseline I need to reset the window to wall ratio to 0.4. Seems like a perfect application to leverage the User Script "Set Window to Wall Ratio".

The problem I'm getting is that it doesn't do anything on my model, even if I try on very simple zones like the following.

Example of one zone

One I select the outdoor surface and apply the measure, nothing changes:

Surface selected

One thing is that, if I create a new space in my model and put a cube in there, the "Set Window to Wall Ratio" user script works like a charm on this.

Can someone offer a clue as to why it doesn't work?

Update: Here is the link to the problematic OSM File if someone can take a look

Set Window to Wall Ratio in Sketchup fails

I'm modeling a building with OpenStudio that has a lot of glazing according to Appendix G, so for the baseline I need to reset the window to wall ratio to 0.4. Seems like a perfect application to leverage the User Script "Set Window to Wall Ratio".

The problem I'm getting is that it doesn't do anything on my model, even if I try on very simple zones like the following.

Example of one zone

One I select the outdoor surface and apply the measure, nothing changes:

Surface selected

One thing is that, if I create a new space in my model and put a cube in there, the "Set Window to Wall Ratio" user script works like a charm on this.

Can someone offer a clue as to why it doesn't work?

Update: Here is the link to the problematic OSM File if someone can take a look