Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Set Render By SurfaceType Colour in OpenStudio

Can you set the rendering colour when using Render By SurfaceType in OpenStudio? I noticed that OpenStudio calls the request_paint method on the model interface for all rendering but SurfaceType.

Set Render By SurfaceType Colour in OpenStudio

Can you set the rendering colour when using Render By SurfaceType in OpenStudio? I noticed that OpenStudio calls the request_paint method on the model interface for all rendering but SurfaceType.

Update All of the rendering views seem to work fine, but when I use render by SurfaceType my model looks like the following: image description It looks like it's in x-ray mode, but it's not. Is there a way to get solid colours back? Is this view expected or does it occur when a method fails?

Set Render By SurfaceType Colour in OpenStudio

Can you set the rendering colour when using Render By SurfaceType in OpenStudio? I noticed that OpenStudio calls the request_paint method on the model interface for all rendering but SurfaceType.

Update All of the rendering views seem to work fine, but when I use render by SurfaceType my model looks like the following: image description It looks like it's in x-ray mode, but it's not. Is there a way to get solid colours back? Is this view expected or does it occur when a method fails?