Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

SWIG director type 'bool' mispatch error when running measures

asked 2024-05-13 18:29:59 -0500

llisell's avatar

updated 2024-05-25 05:00:51 -0500

When I am trying to run measures, I get the following error: SWIG director type mismatch in output value of type "bool"

I watched the youtube videos on running measures (, and have appropriate inputs for space and zones, but the measure still won't run. I am running a model that came out of Asset Score. I am adding a some screenshots below. The first is the error that I am getting when I try and run the measure. image description The second is a screenshot of the spaces tab showing space types assigned to each of the spaces.
C:\fakepath\Screenshot 2024-05-25 055319.png

edit retag flag offensive close merge delete



@llisell you can refer to other posts about SWIG errors here and here. In summary, you'll need to share more information about:

  • what measure you're trying to apply
  • where you got that measure from (if not the BCL)
  • any other error/warning messages from trying to apply the measure
Aaron Boranian's avatar Aaron Boranian  ( 2024-05-13 18:38:23 -0500 )edit

@Aaron Boranian I am trying to run the "CreateBaselineBuilding" measure from BCL to create an ASHRAE 90.1 baseline building. Also added a screenshot of the output screen to the post.

llisell's avatar llisell  ( 2024-05-14 18:01:46 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2024-05-16 05:01:02 -0500

updated 2024-05-25 08:18:38 -0500

Similar to this previous post? I'd check your model for missing space type properties. In a nutshell, the CreateBaselineBuilding Measure has OpenStudio-Standards as a gem dependency. The gem itself (not the measure) is tripping over missing space type properties, which in turn may be generating your more severe error.

EDIT: Double-check space type properties (under "Space Types" tab)?

image description

edit flag offensive delete link more


@Denis Bourgeois this doesn't appear to be the problem, all of my spaces have space types assigned, I added a screenshot above.

llisell's avatar llisell  ( 2024-05-25 05:02:43 -0500 )edit

@llisell : I edited my initial answer. Could you double-check those space types ("Space Types" tab)?

Denis Bourgeois's avatar Denis Bourgeois  ( 2024-05-25 08:19:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops


Question Tools

1 follower


Asked: 2024-05-13 18:29:59 -0500

Seen: 102 times

Last updated: yesterday