Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
0

How do I turn on/off PTAC at right temperature?

asked 2023-05-04 17:15:46 -0500

kwon1579's avatar

updated 2023-05-26 16:16:22 -0500

C:\fakepath(4).png
https://tinyurl.com/energyplusQ
Please refer to the photo and file above (part of my EnergyPlus)

How do I make my PTAC/Thermostat so that it turns on when thermostat temperature is out of range and turns off during the range of given deadband? I feel like I am doing something wrong on "Scheduling" but not sure how to include "Temperature" in that ScheduleCompact. If this is possible, would you mind showing me the example?

edit retag flag offensive close merge delete

Comments

@kwon1579 is this the same issue as your other post? If so, I'll close that other one.

Aaron Boranian's avatar Aaron Boranian  ( 2023-05-07 07:18:11 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2023-05-05 14:11:14 -0500

You have a ThermostatSetpoint:DualSetpoint but no ZoneControl:Thermostat. You need to include a ZoneControl:Thermostat that references your thermostat setpoint.

Ex:

ZoneControl:Thermostat,
  Floor 2 Exam 2 Thermostat,  !- Name
  Floor 2 Exam 2,    !- Zone or ZoneList Name
  Floor 2 Exam 2 Thermostat Type Sched,  !- Control Type Schedule Name
  ThermostatSetpoint:DualSetpoint,  !- Control 1 Object Type
  Floor 2 Exam 2 Setpoints;  !- Control 1 Name

Schedule:Constant,
  Floor 2 Exam 2 Thermostat Type Sched,  !- Name
  Control Type,            !- Schedule Type Limits Name
  4;                       !- Hourly Value

ThermostatSetpoint:DualSetpoint,
  Floor 2 Exam 2 Setpoints,  !- Name
  Floor 2 Exam 2 Heating Setpoint Sch,  !- Heating Setpoint Temperature Schedule Name
  Floor 2 Exam 2 Cooling Setpoint Sch;  !- Cooling Setpoint Temperature Schedule Name
edit flag offensive delete link more

Comments

No I have ZoneControl:Thermostat if you visit the tinyurl it will show you PNG is just part of it

kwon1579's avatar kwon1579  ( 2023-05-05 14:42:43 -0500 )edit

Ok it's because the Fan Operating Mode Schedule is set to Always 1. Always 1 for a fan operating schedule means it'll always be running. Set it to Always 0 for a cycling fan. However, you can't set the fan operation to cycling for a constant volume fan. So, change the fan type to Fan:OnOff, then set the operating schedule in ZoneHVAC:PackagedTerminalAirConditioner to Always 0. See here.

ericmartinpe's avatar ericmartinpe  ( 2023-05-05 14:58:23 -0500 )edit

thank soooooo much and sorry but how do I fix this....?

* Severe * GetZoneAirSetpoints: Could not find ThermostatSetpoint:DualSetpoint Schedule=BERG
THERMOSTAT SETPOINT
* Severe * GetStagedDualSetpoint: Errors with invalid names in
ZoneControl:Thermostat:StagedDualSetpoint objects.
* ~~~ * ...These will not be read in. Other errors may occur.

kwon1579's avatar kwon1579  ( 2023-05-05 17:43:23 -0500 )edit

Create a DualSetPoint object with the name BERG THERMOSTAT SETPOINT. It should look like this with the names of your cooling and heating temp schedules.

ThermostatSetpoint:DualSetpoint,
  BERG THERMOSTAT SETPOINT,    !- Name
  HTGSETP_SCH,             !- Heating Setpoint Temperature Schedule Name
  CLGSETP_SCH;             !- Cooling Setpoint Temperature Schedule Name
rraustad's avatar rraustad  ( 2023-05-05 17:52:30 -0500 )edit

Oh, wait, that's wrong. The error is saying it can't find a schedule. Search your input file and see where this name is used and correct accordingly.

rraustad's avatar rraustad  ( 2023-05-05 17:54:46 -0500 )edit
1

answered 2023-05-05 14:56:40 -0500

updated 2023-05-05 15:30:46 -0500

Use a schedule like this for the PTAC Supply Air Fan Operating Mode Schedule. You can actually use any Schedule Type Limits Name that includes 0 - 1 but if you paste this into your input file and copy the name of this schedule to the Supply Air Fan Operating Mode Schedule Name field you should get the operation you are looking for.

Schedule:Compact,
  SAFan_OpMode_Sch,        !- Name
  Fraction,                !- Schedule Type Limits Name
  Through: 12/31,          !- Field 1
  For: AllDays,            !- Field 2
  Until: 24:00,0.0;        !- Field 3

ScheduleTypeLimits,
  Fraction,                !- Name
  0.0,                     !- Lower Limit Value
  1.0,                     !- Upper Limit Value
  CONTINUOUS;              !- Numeric Type
edit flag offensive delete link more

Comments

that gives me this error :/
* Fatal * GetPTUnit: Errors found in getting input.
...Summary of Errors that led to program termination:
..... Reference severe error count=1
..... Last severe error=ZoneHVAC:PackagedTerminalAirConditioner "PTAC DX CLG ELEC HTG"

kwon1579's avatar kwon1579  ( 2023-05-05 16:12:21 -0500 )edit

Sorry this also (Severe error)
* Severe * ZoneHVAC:PackagedTerminalAirConditioner "PTAC DX CLG ELEC HTG"
* ~~~ * Fan operating mode must be continuous (fan operating mode schedule values > 0) for supply
fan type Fan:ConstantVolume.
* ~~~ * Error found in Supply Air Fan Operating Mode Schedule Name = SAFAN_OPMODE_SCH
* ~~~ * schedule values must be (>0., <=1.)

kwon1579's avatar kwon1579  ( 2023-05-05 16:14:24 -0500 )edit

As @ericmartinpe mentioned, you can't use a Fan:ConstantVolume fan type with cycling fan mode. Change the fan type to OnOff and then you should not get that severe error.

rraustad's avatar rraustad  ( 2023-05-05 16:39:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Careers

Question Tools

1 follower

Stats

Asked: 2023-05-04 17:15:46 -0500

Seen: 114 times

Last updated: May 12 '23