Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

[EnergyPlus] ThermostatSetpoint:DualHeatingCooling

asked 2023-05-04 12:35:39 -0500

kwon1579's avatar

Right now, I am using ZoneHVAC:PTAC with ThermostatSetpoint:DualHeatingandCooling.
The heating is set to 20C and cooling is set to 24C.

But the thing is, when I execute this IDF (it is meant to run entire year with timestep of 15 minutes), the heating turns on even when the temperature is greater than 20 (sometimes 24). Furthermore, the meaning of "heat below 20C" and "cool above 24C" means there is deadband temperature between 20 and 24. But this dude NEVER TURNS OFF... please help! I have uploaded my idf file in this link ( I am using given SanFrancisco weather File )

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2023-05-04 12:41:04 -0500

Is it the fan that never turns off, or the coils? The fan is set to run all the time:

  PTAC DX Clg Elec Htg,    !- Name
  Always On Discrete hvac_library;  !- Supply Air Fan Operating Mode Schedule Name
edit flag offensive delete link more


the output values of "PTAC DX CLG ELEC HTG:Zone Packaged Terminal Air Conditioner Total Cooling Energy J" and "PTAC DX CLG ELEC HTG:Zone Packaged Terminal Air Conditioner Total Heating Energy J" are just always there (without both being zero) . How do I design it so that the system Heating turns off above 20C and Cooling turns off below 24C?

kwon1579's avatar kwon1579  ( 2023-05-04 12:44:51 -0500 )edit

The Always On Discrete hvac_library is name of the Schedule:

Schedule:Constant,Always On Discrete hvac_library,OnOff hvac_library,1;

kwon1579's avatar kwon1579  ( 2023-05-04 12:48:27 -0500 )edit

Those reports are telling you that the air blowing into the zone has some energy content. The supply air temperature with respect to the zone (Tsupply - Tzone) will be non-zero even when the coils are off. Look at the coil electricity rate to see if those components are on. If you don't want the fan to run all the time change the Supply Air Fan Operating Mode Schedule to 0 so the fan can cycle with the coils. Or if you want cycling fan at night and constant fan during occupied hours, change the Supply Air Fan Operating Mode Schedule accordingly.

rraustad's avatar rraustad  ( 2023-05-04 12:49:09 -0500 )edit

is there no way to tell them
"run when above 20C"?

kwon1579's avatar kwon1579  ( 2023-05-04 12:51:34 -0500 )edit

when I changed Schedule:Constant,Always On Discrete hvac_library,OnOff hvac_library,1; this to zero to turn off, it gave me fatal error :(. Is there a way for it to turn on only on appropriate/desired temperature range?

kwon1579's avatar kwon1579  ( 2023-05-04 12:54:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops


Question Tools

1 follower


Asked: 2023-05-04 12:35:39 -0500

Seen: 88 times

Last updated: May 04 '23