Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Openstudio error: simulation failed to run, with exit code 1

asked 2022-10-14 04:01:27 -0600

MK's avatar

updated 2022-10-17 05:54:46 -0600

Im new to open studio but got the following error which I can't resolve. The error looks like:

stderr: sh: line 1: 38583 Abort trap: 6           
"/Applications/OpenStudioApplication1.4.0/OpenStudioApp.app/Contents/EnergyPlus/energyplus" 2>&1
EnergyPlus returned a non-zero exit code. Check the stdout-energyplus log.

I have read about an eplus.err file to see the specific error but I don't get this file. For different idf files I get the same error. Also with files that are originally from energyplus to practice with.

Hope anyone can help me with this problem!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-10-17 03:24:52 -0600

On the Run Tab, click the "Verbose Output" checkbox at the top and try to see if you can get more information.

Also, try to see if you can run the E+ executable itself. Open your Terminal and type:

/Applications/OpenStudioApplication1.4.0/EnergyPlus/energyplus --help

edit flag offensive delete link more

Comments

Dear Julien,

Thank you for your answer! I tried to click the "Verbose Output" checkbox but I don't seem to get much information from that. When the line in my terminal I got the following:


dyld: Symbol not found: __ZTINSt3__14__fs10filesystem16filesystem_errorE Referenced from: /Applications/OpenStudioApplication-1.4.0/EnergyPlus/libenergyplusapi.22.1.0.dylib (which was built for Mac OS X 10.15) Expected in: /usr/lib/libc++.1.dylib in /Applications/OpenStudioApplication-1.4.0/EnergyPlus/libenergyplusapi.22.1.0.dylib Abort trap: 6


Do you maybe know what I am doing wrong?

MK's avatar MK  ( 2022-10-17 05:53:16 -0600 )edit

E+ doesn't run because your macOS system version is too old to support the std::filesystem from C++17. What version are you using? You need 10.15 or above

Julien Marrec's avatar Julien Marrec  ( 2022-10-17 07:49:03 -0600 )edit

Thank you! This was indeed the case

MK's avatar MK  ( 2022-10-20 07:40:35 -0600 )edit

Please mark the answer as accepted so the thread is marked resolved (green check mark below the Up/Down vote buttons). Thanks

Julien Marrec's avatar Julien Marrec  ( 2022-10-20 08:13:16 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

1 follower

Stats

Asked: 2022-10-14 04:01:27 -0600

Seen: 613 times

Last updated: Oct 20 '22