Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
0

Error when using "Add wind and stack open area" measure

asked 2022-06-26 03:39:32 -0500

Emma's avatar

updated 2022-07-05 04:24:13 -0500

Hello everyone, I’m modeling natural ventilation in a residential building. For this, I downloaded the “Add wind and stack open area” measure and I get this error : "No windows found in selection matching given construction. This means your model lacks windows or lacks windows with the specified construction". An operable window construction is defined, and I checked that it’s well applied to my window construction at spaces -> subsurface tab. I followed all the steps mentioned here : https://unmethours.com/question/30885... but the problem remains the same and I saw that it’s the case for many other people too. If anyone has a suggestion or a solution, I’ll be more than thankful. as suggested : subsurface type : window, outside boundary condition : outdoors

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2022-06-30 09:37:50 -0500

The measure works by:

  1. Retrieving all FenestrationSurface:Detailed objects.
  2. Checking that the object's Surface Type is "Window".
  3. Checking that the object's Outside Boundary Condition is "Outdoors".
  4. Checking that the object's Construction Name matches the provided construction name (optional).

If that still doesn't help you figure it out, please provide a link to your model via, e.g., Google Drive or Dropbox.

edit flag offensive delete link more

Comments

I checked the Surface type and outside boundary condition and they are as you suggested. when opening the file on bloc note, there doesn't seem to be any FenestrationSurface:Detailed object. Please find below a link to my model https://drive.google.com/file/d/1IM6a... I also wanted to know if I set the zone equipment in the Thermal zone tab as "Zone Ventilation wind and stack open area" from the library, wil that be equivalent to using the" Add ventilation as stack open area" measure ?

Emma's avatar Emma  ( 2022-07-05 04:30:27 -0500 )edit

I ran the measure on your model and found that the measure does not work as of EnergyPlus v9.6. I filed a bug report here.

shorowit's avatar shorowit  ( 2022-07-05 09:36:15 -0500 )edit

Thank you very much, could you please advise what can I do now to resolve the problem ?

Emma's avatar Emma  ( 2022-07-05 14:54:23 -0500 )edit

Until the measure is fixed, I think your only real option is to use an older version of the openstudio application. It seems like version 1.2.0 should work because it uses EnergyPlus v9.5, but I haven't tested it.

shorowit's avatar shorowit  ( 2022-07-06 10:17:14 -0500 )edit

Before I reinstall earlier version of openstudio just wondering if there is going to be any movement soon on this bug fix, as I also need this measure for current work which is becoming urgent.

Bill's avatar Bill  ( 2022-07-23 01:20:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

1 follower

Stats

Asked: 2022-06-26 03:39:32 -0500

Seen: 72 times

Last updated: Jul 05