Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
0

EnergyPlus reported area is 0 (m^2). OpenStudio reported area is 684 (m^2).

asked 2021-10-28 05:13:38 -0500

etravis.asia's avatar

Running the model, and I get this error, as stated above:

EnergyPlus reported area is 0 (m^2). OpenStudio reported area is 684 (m^2).

The dump is as follows, can anyone explain what to do?

Envelope Summary section failed and was skipped because: Wrong arguments for overloaded method 'toNeatString'. Possible C/C++ prototypes are: std::string toNeatString(double value, unsigned int numFractionalDigits, bool applyCommas) std::string toNeatString(double value, unsigned int numFractionalDigits) std::string toNeatString(double value) . Detail on error follows: C:/Users/Euroland/AppData/Local/Temp/osmodel-1635413685-1/resources/measures/OpenStudioResults/resources/os_lib_reporting.rb:1752:in toNeatString' C:/Users/Euroland/AppData/Local/Temp/osmodel-1635413685-1/resources/measures/OpenStudioResults/resources/os_lib_reporting.rb:1752:inblock in envelope_section_section' C:/Users/Euroland/AppData/Local/Temp/osmodel-1635413685-1/resources/measures/OpenStudioResults/resources/os_lib_reporting.rb:1736:in each' C:/Users/Euroland/AppData/Local/Temp/osmodel-1635413685-1/resources/measures/OpenStudioResults/resources/os_lib_reporting.rb:1736:inenvelope_section_section' (eval):1:in block in run' C:/Users/Euroland/AppData/Local/Temp/osmodel-1635413685-1/resources/measures/OpenStudioResults/measure.rb:289:ineval' C:/Users/Euroland/AppData/Local/Temp/osmodel-1635413685-1/resources/measures/OpenStudioResults/measure.rb:289:in block in run' C:/Users/Euroland/AppData/Local/Temp/osmodel-1635413685-1/resources/measures/OpenStudioResults/measure.rb:286:ineach' C:/Users/Euroland/AppData/Local/Temp/osmodel-1635413685-1/resources/measures/OpenStudioResults/measure.rb:286:in run' :/ruby/2.7.0/gems/openstudio-workflow-2.2.0/lib/openstudio/workflow/util/measure.rb:519:inapply_measure' :/ruby/2.7.0/gems/openstudio-workflow-2.2.0/lib/openstudio/workflow/util/measure.rb:114:in block in apply_measures' :/ruby/2.7.0/gems/openstudio-workflow-2.2.0/lib/openstudio/workflow/util/measure.rb:67:ineach_index' :/ruby/2.7.0/gems/openstudio-workflow-2.2.0/lib/openstudio/workflow/util/measure.rb:67:in apply_measures' :/ruby/2.7.0/gems/openstudio-workflow-2.2.0/lib/openstudio/workflow/jobs/run_reporting_measures.rb:119:inperform' :/ruby/2.7.0/gems/openstudio-workflow-2.2.0/lib/openstudio/workflow/run.rb:292:in step' :/ruby/2.7.0/gems/openstudio-workflow-2.2.0/lib/openstudio/workflow/run.rb:234:inrun' :/openstudio_cli.rb:1013:in execute' :/openstudio_cli.rb:803:inexecute' :/openstudio_cli.rb:1797:in ' eval:185:ineval' eval:185:in require_embedded_absolute' eval:170:inblock in require_embedded' eval:164:in each' eval:164:inrequire_embedded' eval:123:in require' eval:3:in). OpenStudio reported area is 684 (m^2).

edit retag flag offensive close merge delete

Comments

Didn't you already have this answered here? https://unmethours.com/question/55873...

shorowit's avatar shorowit  ( 2021-10-28 14:38:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-10-28 10:10:00 -0500

Most likely cause is that your OpenStudio spaces are not assigned to Thermal Zones. This can be done in the Space tab in the OpenStudio Application which has a column for thermal zone assignment. If you have not already done so you should make thermal zones and those will in turn be connected to the HVAC system.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

1 follower

Stats

Asked: 2021-10-28 05:13:38 -0500

Seen: 106 times

Last updated: Oct 28 '21