Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

Is there a bug in Openstudio 1.2.0 where creating over 127 spaces breaks gridview?

asked 2021-08-18 03:40:43 -0500

gclark gravatar image

updated 2021-08-19 00:19:22 -0500

We have recently upgraded to OpenStudio 3.2.0 and in the process have been modelling spaces using SketchUp 2021 and the OpenStudioApp 1.2.0. We have found that modelling 128 spaces breaks the space, surface and subsurface tabs in the OpenStudioApp 1.2.0 in which no model information shows on the screen. This tab works perfectly fine with 127 spaces. We can also revert from 128 to 127 spaces and the information shows up again.

Creating spaces been tested on three different machines and I have tried the following methods, of which none work successfully past 127 spaces:

  1. Creating spaces in SketchUp 2021 using the OpenStudio Plugin for 3.2.0
  2. Creating the spaces manually in the OpenStudio application 1.2.0
  3. Creating the spaces using Ladybug Tools in Rhino3d v7

The only success we have had is in upgrading a previous model from OpenStudio 2.7.1, where the information shows for a model with 320 spaces.

Does anyone have any potential fixes or other workflows around this possible limitation?

edit retag flag offensive close merge delete

Comments

Hi @gclark, have you tried the Pollination Rhino plugin? There is no limitation on the number of zones that you can model. Here is a model with 253 zones. You can download the latest version from here.

Mostapha Roudsari gravatar image Mostapha Roudsari  ( 2021-08-18 09:10:23 -0500 )edit

Hi Mostapha, I will try the Pollination plugin, however this appears to be an issue on the OpenStudio Application rather than the space creation process that we are trying to solve.

gclark gravatar image gclark  ( 2021-08-19 00:18:20 -0500 )edit

@Julien-Marrec, we have not yet filed an issue on the github before confirming the nature of the problem

gclark gravatar image gclark  ( 2021-08-19 00:19:10 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
5

answered 2021-08-19 03:00:47 -0500

It doesn't break the space tab. It just runs super slow due to a stack overflow. It only affects windows. I just created a model with 300 spaces and can display them fine after a while on windows.

This issue has already been filled at OpenStudioApplication#378 and fixed in PR #390, and should be in the next release of the OpenStudioApplication who should come out soon now.

We apologize for any inconvenience, and for what it's worth we would gladly welcome anyone who is willing to try out our release candidates to catch these types of problems early on. I have just launched a v1.2.1-rc1 (Release candidate 1) that should fix this issue. Please try it out: https://github.com/openstudiocoalitio...

edit flag offensive delete link more

Comments

1

@gclark, please let us know if v1.2.1-rc1 makes your issue disappear, thanks!

Julien Marrec gravatar image Julien Marrec  ( 2021-08-19 09:21:16 -0500 )edit

Thank you for the explanation Julien, we have downloaded and tried the v1.2.1-rc1 version of the application and it works well for what we have tried so far.

We appreciate the help and the quick response. It would be great to get involved with the release candidates and provide feedback where possible. How would you prefer the feedback on rc-1? On github or an email or another method?

gclark gravatar image gclark  ( 2021-08-19 22:41:45 -0500 )edit

There is a pinned issue on GitHub for reporting any issues you find with the v1.2.1-rc1 installer. Any feedback on there is greatly appreciated!

macumber gravatar image macumber  ( 2021-08-22 11:42:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2021-08-18 03:40:43 -0500

Seen: 126 times

Last updated: Aug 19