Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

Simulation Failed.

asked 2021-03-04 21:24:30 -0600

shmily_world gravatar image

updated 2021-04-13 10:26:12 -0600

"Initializing workflow. Processing OpenStudio Measures. Applying EnableDetailedOutputForEachNodeInALoop Result: Fail Error: Script argument 'loop' is required, but the user argument does not have a value or default value set. Failed."

Everytime I run my simulation it gives me this message. What's the problem and how to solve it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2021-03-05 09:06:15 -0600

It looks like you are trying to apply an OpenStudio Measure named EnableDetailedOutputForEachNodeInALoop, which I found on the BCL (Building Component Library). That measure requires that you provide the name of a loop (central air system, chilled water plant, hot water plant, etc.) to create detailed outputs for. As the message says,

Script argument 'loop' is required, but the user argument does not have a value or default value set.

If you are using the OpenStudio Application, you need to go to the Measures tab (paper icon on the left edge), click on the name line for this measure, then set a loop name in the model as part of the measure inputs on the right (see below).

image description

In general, when you see red text in a list of measure inputs on the right, that is a required input that cannot be left blank. Also, the red triangle symbol at the right of a measure name in the OpenStudio Application indicates the same information.

edit flag offensive delete link more

Comments

Thanks. I think you are right. I solved this problem while another problem emerges. It says sth about 'input argument', saying that it was not found or might be removed by other measures. Do u know what this message indicates?

shmily_world gravatar image shmily_world  ( 2021-03-08 23:34:49 -0600 )edit

@shmily_world if this is a new problem, then please create a new post with screen shot images, links to model files, etc. so that others can help you resolve it. If the answer above resolves your original problem, then please up-vote and/or click on the check mark to the left of the post to accept it as the correct answer.

Aaron Boranian gravatar image Aaron Boranian  ( 2021-03-09 09:14:48 -0600 )edit

Thx and I will follow your suggestion.

shmily_world gravatar image shmily_world  ( 2021-03-10 00:02:58 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

Stats

Asked: 2021-03-04 21:24:30 -0600

Seen: 54 times

Last updated: Mar 10