Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Problem with "Project loose geometry"

asked 2020-09-07 08:41:38 -0500

rainbow gravatar image

updated 2020-09-08 08:19:39 -0500

I'm drawing a building with SketchUp Pro 2019 + OpenStudio Plugin.

I have a problem with the "Project loose geometry" button, present on the "OpenStudio Plugin" toolbar.

This is the situation before pressing that button: C:\fakepath\Screeshot_07-09-2020_5.PNG

As you can see, there are 11 windows (each of them is created by drawing a rectangle by using the "Shapes" button on the SketchUp toolbar).

Then, after selecting the entire drawing, I press the "Project Loose Geometry" button, and then I select the "Project Selected Loose Geometry" option.

Now, what I obtain is this: C:\fakepath\Screeshot_07-09-2020_6.PNG

So, unfortunately, a window remains unaltered, after executing the "Project Loose Geometry".

My problem is similar to this, and it seems no one found a solution.

Is there anyone who could help me?

Thank You!

edit retag flag offensive close merge delete

Comments

1

At first glance, it doesn't look like it was ignored, but for some reason split the main base surface into two base surfaces. Is it possible that sub-surface goes to the ground, as I wouldn't expect that behavior from a window that doesn't go to the button edge. Either way if you go into the space and delete one edge of the sub-surface, maybe the top, and then draw it back, what happens? Does it become a sub-surface then?

David Goldwasser gravatar imageDavid Goldwasser ( 2020-09-08 12:22:09 -0500 )edit

Hi David, thanks for your interest. I tried to start the drawing from scratch many times, but I always got the same results: what changed was only that the error was not always regarding the same window. I have not had the opportunity to investigate the cause too much, but, apparentely, I found a work-around. I'll write it outside this comment, to make it more visible to future readers.

rainbow gravatar imagerainbow ( 2020-09-09 09:54:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-09-09 09:56:40 -0500

rainbow gravatar image

Apparentely, I found a work-around: after selecing and right-clicking on the building portion of interest, select "Edit Group", and then erase the four edges of the window not well treated by the command. Then, re-draw the window with the "Shapes" command, select the entire drawing and click on the "Project Loose Geometry" button.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2020-09-07 08:41:38 -0500

Seen: 52 times

Last updated: Sep 09