Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

readvars auto outputs zone temp and humidity

asked 2020-08-07 08:12:39 -0600

dbullock gravatar image

updated 2020-08-07 09:06:32 -0600

I am trying to view a variety of hourly Output Variables using readvars eso to calibrate my model. The eso output always contains zone temp and humidity (not asked for), which max out my 255 column limit, so I cannot view my selected output variables (unless I select another Zone variable, which integrates itself with each zone temp and humidity column group). Even in this case my 255 max limits the number of zones I can see.

In Open Studio I have turned Possible Output Variables "All Off", ensuring that zone temp and humidity are not selected. However, they always remain a part of the eso output. I've tried this a couple ways with no success. Is this is a default setting that I cannot change? Is there something I've overlooked? Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2020-08-07 09:05:50 -0600

By default, OpenStudio adds the Zone Mean Air Temperature and Zone Relative Humidity output variables to a simulation IF you are applying the OpenStudio Results reporting measure. To avoid the max 255 column limit when using ReadVars to convert the ESO output file into a CSV file, you have a few options:

  • Don't apply the OpenStudio Results reporting measure so that only the output variables you request are generated.
  • Avoid ReadVarsESO to generate a CSV altogether and instead use an ESO file reader. This will avoid the max 255 columns limit and have better/faster plotting capabilities than Excel.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2020-08-07 08:12:39 -0600

Seen: 195 times

Last updated: Aug 07 '20