Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
0

MapShadeDeployment Warning

asked 2019-12-18 17:33:15 -0600

avril14 gravatar image

updated 2020-01-07 17:19:01 -0600

I'm getting thousands of the same warning and it's actually crashing my model without any errors. image description

* Warning * MapShadeDeploymentOrderToLoopNumber: found empty map for window in zone LO2 OFFICEW5 THERMALZONE

I'm not sure what this is referring to, any suggestions on how to fix it? Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-12-18 17:41:46 -0600

updated 2019-12-18 17:42:29 -0600

There is a comment in this EnergyPlus GitHub issue where @MJWitte says "This is a false warning which happens because not every window in [the zone] is included in the WindowShadingControl. The logic in MapShadeDeploymentOrderToLoopNumber does not currently anticipate this possibility." Does that situation reflect your model as well?

If so, it seems like the possibilities are 1) include every window in the zone in the WindowShadingControl or 2) post in the GitHub issue that this results in a crash so that it's prioritized and addressed in the next EnergyPlus release.

edit flag offensive delete link more

Comments

Hm ok, I tried to assign multiple shading controls to the same zone so that's probably what's doing it. I'll try to simplify a bit to get it running. Thank you!

avril14 gravatar imageavril14 ( 2019-12-18 18:10:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2019-12-18 17:33:15 -0600

Seen: 37 times

Last updated: Dec 18 '19