Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

OpenStudio model will not show in SketchUp

asked 2019-05-07 21:54:38 -0500

R1cardo gravatar image

updated 2019-05-09 15:20:52 -0500

Hey guys,

I'm working in OpenStudio 2.8.0. and SketchUp 2017 version 17.2.2555. I created my geometries in Sketchup before moving on to create my constructions, zones, systems. When I went to run the model I had failures relating to "degenerate" surfaces. From reading other posts here, I learned I needed to go back and edit m geometries to tighten them up. However, when I try to open the OSM through the Sketchup plugin I get this error for multiple surfaces: "Sub Surface 2 This sub surface's base surface 'Surface 503' does not have a face polygon, it cannot be drawn." I click ok and nothing pops up. However, I open the model inspector and everything pops up in there. On other posts I read that they would appear if they double click on an element in the inspector, but mine will not produce that. It just stays blank.

I did already try and uninstall/reinstall both softwares. If anyone thinks they might have a lead, I would appreciate it. Or if you need more info, let me know.

Update: I went into the code and deleted the surfaces that had been reported in the error as degenerate. That still will not get my model to show. Going to try and do that with the subsurfaces as recommended below. The script does not work for that as no model is visually shown.

I did go back through the models I had archived and it seems like the model stopped working in Sketchup either after forming zones or surface matching.

edit retag flag offensive close merge delete

Comments

Try the following: Load the osm file into SketchUp. Export it as an idf file. Open the stand alone EnergyPlus EPLaunch menu and locate the exported idf file. Locate your weather file. Click on the Edit IDF-Editor button. In the Class List scroll down to the Output Reporting Class and create an Output:Diagnostics object by clicking on the New Object button and selecting DisplayExtraWarnings in the drop down box. Save the file. Go back to EP Launch and click the Simulate button. Whether the simulation runs or fails click on the Errors button to read the errors and warnings.

RCulham gravatar imageRCulham ( 2019-05-10 16:06:09 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2019-05-08 14:23:00 -0500

RCulham gravatar image

You may also try with a backup copy of your osm file the following:

Within Sketchup go to:

Extensions\OpenStudio User Scripts\Alter or Add Model Elements\Remove Orphan SubSurfaces

Then you may have to redraw your main surfaces. If surfaces are not coplanar (for example all surface vertices are in the same plane, ie the Z coordinate is the same for all vertices), then errors can occur.

edit flag offensive delete link more

Comments

So I'm looking at this right now and the error prompt actually has the error for every single window. Could this be due to the fact that the model is not loading at all and it is looking for the surfaces to place the subsurfaces on but cannot find them?

I did try and run the srcipt even without being able to see it, and it just tells me that there are no subsurfaces to remove, even though I have 37 total in the inspector and when the error prompt shows up.

R1cardo gravatar imageR1cardo ( 2019-05-09 11:25:33 -0500 )edit
1

answered 2019-05-08 10:18:39 -0500

Open the .osm file in a text editor and delete the offending surfaces (Sub Surface 2 and Surface 503). Then re-open in Sketchup and re-do that portion of the geometry. My guess is this is the result of a wall that is slightly off from being a plane, and the window on it can't anchor to a non-planar surface.

edit flag offensive delete link more

Comments

So, I think I'm going to try this first with my degenerate surfaces. I think that the subsurfaces error is popping up because the model is not loading. The error actually shows up for all the subsurfaces. I tried removing the subsurfaces with the script RCulham mentioned above and it cannot pick them up, even though the inspector shows them.

R1cardo gravatar imageR1cardo ( 2019-05-09 11:27:59 -0500 )edit

what happens when you load your model in the OpenStudio App and look in the geometry tab?

mdahlhausen gravatar imagemdahlhausen ( 2019-05-09 15:04:24 -0500 )edit

I am able to see the spaces modeled in the geometry tab.

R1cardo gravatar imageR1cardo ( 2019-05-09 15:17:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 



Question Tools

Stats

Asked: 2019-05-07 21:54:38 -0500

Seen: 84 times

Last updated: May 09