Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question

Run energyplus without executing ReadVarsESO at the end of simulation (Linux, command line)

asked 2019-05-03 05:50:34 -0600

Julian gravatar image

updated 2019-05-03 07:39:34 -0600

Dear All,

I would like to run energyplus with command line arguments producing the standard eplusout.eso (after specifying Output:Variable in the idf file), but I do not want to have ReadVarsESO executed automatically after energyplus completes. (In order to obtain the results file in csv format I will call ReadVarsESO explicitly after energyplus completes).

I am aware of the energyplus option ( -r, --readvars, Run ReadVarsESO after simulation). My understanding is that by default ReadVarsESO is not executed after energyplus completes, but for some reason it does run for my case.

I am running under Linux, and executing energyplus (EnergyPlus, Version 9.0.1-bb7ca4f0da1) from the command line with command line arguments.

Any thoughts on how to force ReadVarsESO not to be executed would be greatly appreciated.

Thank you.

P.S. Not having ReadVarsESO run after energyplus might seem a bit unusual, but it is related to running independent energyplus processes in parallel under linux from command line (as described in a recent post

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-05-03 13:11:50 -0600

From this Running EnergyPlus by Hand documentation for EP v9.0.1, you can type energyplus --help or man energyplus to see details for available CLI arguments.

From this CLI guide on GitHub, it doesn't explicitly say that there is a default setting for the -r or --readvars option.

If those two steps aren't giving enough help, then perhaps there is a " -r " in the file path of the EPW or IDF file you are using, and CLI is interpreting that as triggering the readvars option. Although, if that were the case, then your simulations would likely be failing and not finding the file in question correctly. Just to be safe, try enclosing EPW and IDF file names with "" to avoid that as a possible issue.

A final explanation is that you've found a bug in the Linux version of the CLI. I've done a few runs on my Windows CLI leaving out -r and it doesn't run Readvars, as desired.

edit flag offensive delete link more


Dear Aaron,

Thank you very much for your prompt and detailed reply.

In fact, there was a bug in my script and i had a "=r" option deeper in my script left from its early stages. Your reply helped me find it. Thank you very much. Greatly appreciated.

Kind regards, Julian

Julian gravatar image Julian  ( 2019-05-03 18:27:29 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer


Question Tools

1 follower


Asked: 2019-05-03 05:50:34 -0600

Seen: 286 times

Last updated: May 03 '19