Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

openstudio build failed

asked 2019-02-03 09:31:39 -0500

ngkhanh gravatar image

updated 2019-02-04 16:55:20 -0500

I tried to build OpenStudioCore for Python Binding build. It shows up the error code as below after downloading all components. How to get out of this ?
I used CMake 3.13.2 with VS Studio 2013 Update 5 x64 on Window 10 x64.

Searching 16 bit integer CMake Error at C:/ProgramFiles/CMake/share/cmake-3.13/ModulesTestBigEndian.cmake:49
(message): no suitable type found
Call Stack (most recent call first):
src/geographic_lib/CMakeLists.txt:236 (test_big_endian)

Configuring incomplete, errors occurred!
Updated: CMake configuration - i am using develop branch CMake Configuration

edit retag flag offensive close merge delete

Comments

Which branch/tag are you trying to build? current develop?

Julien Marrec gravatar imageJulien Marrec ( 2019-02-04 04:45:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2019-02-04 09:30:27 -0500

Couple of things to check:

  1. Python bindings aren't officially supported, check that you can build OpenStudio without them first before enabling them.
  2. Follow these instructions to set up your build environment. You may also want to follow these ones.
  3. Make sure to check out the develop or master branch of OpenStudio on git.
  4. When you configure, make sure that the source directory is set as "\openstudio\openstudiocore" and not the root "\openstudio" directory (see image below).

image description

edit flag offensive delete link more

Comments

@macumber I did exactly like instructions and still got the same error. The configuration updated in my question. Thanks

ngkhanh gravatar imagengkhanh ( 2019-02-04 14:23:30 -0500 )edit

It is very important to follow these instructions exactly. Specifically, you should make sure that the PreferredToolArchitecture environment variable is set to x64. See how to set an environment variable on Windows. Once you set this environment variable, I would delete your build directory and try again. We just hit this issue on a build machine here, the environment variable fixed it.

macumber gravatar imagemacumber ( 2019-02-11 17:04:28 -0500 )edit

Be sure to set the environment variable permanently, not just in a command prompt session.

macumber gravatar imagemacumber ( 2019-02-11 17:05:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2019-02-03 09:31:39 -0500

Seen: 87 times

Last updated: Feb 04