Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

"Error parsing "Schedule:File". Error in following line" in E+ 8.9

asked 2018-09-15 19:09:48 -0500

sajithwjay gravatar image

updated 2018-09-16 07:31:59 -0500

I have created an IDF in E+ 8.8 and then updated to 8.9. Once it runs in one of my work stations it gives me the following error sequence related to the "schedule file". However when I run it in my other work station and the laptop in 8.9, it runs, gives out timestep results with rapid fluctuations and I have posted that error in a recent previous question here,

https://unmethours.com/question/34049...

image description

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2018-09-17 07:35:27 -0500

updated 2018-09-17 11:53:21 -0500

Without seeing the IDF file, you have a stray comma, semicolon, or newline.

In fact, it looks like the parser might be struggling with the "\r" that is part of your path for the file. If this is the case, then this is a bug in the parser.

Edit: It was a bug in the input parser.

edit flag offensive delete link more
2

answered 2018-09-17 09:50:20 -0500

From the error message, I believe the problem may just be the path to the CSV file. Try putting the CSV file in the same folder as the IDF and use a relative path or if that doesn't work, try putting the CSV file in a folder close to the root (like c:\temp) and see if that works.

edit flag offensive delete link more

Comments

Both of these suggestions should avoid the input parser bug and should be used as a workaround for EnergyPlus 8.9.

MarkAdams gravatar imageMarkAdams ( 2018-09-17 11:57:12 -0500 )edit
1

answered 2018-09-16 06:42:57 -0500

Avi gravatar image

I am taking a wild guess here: Make sure the encoding of that file are UTF-8 and not something else. In many cases I saw that was it.

edit flag offensive delete link more

Comments

Thank you very much for your response. The file was not in UTF-8. I changed it to UTF-8. However, it didn't solve the issue. Still yields the same error message.

sajithwjay gravatar imagesajithwjay ( 2018-09-16 14:59:50 -0500 )edit

@sajithwjay could you post a link to the files and to your idf file? Make sure that after changing to UTF-8 there are not any odd characters in the text.

Avi gravatar imageAvi ( 2018-09-17 02:43:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 



Question Tools

1 follower

Stats

Asked: 2018-09-15 19:09:48 -0500

Seen: 165 times

Last updated: 2 days ago