Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Zone Component Load Summary not generated with Eppy scripts

asked 2018-06-11 18:59:48 -0500

Yueyue_Zhou gravatar image

updated 2018-06-11 19:29:23 -0500

I am now working on the Eppy scripts to run EnergyPlus building simulation and do system sizing. I have a few questions about zone load results and eppy scripts:

I used the "Ideal Air Loads" to calculate the zone load first, and later, I am going to use the load values to pick up the right HVAC system devices and run the energy simulation. Now after running the "Ideal Air Loads" model, there's an "HVAC sizing summary" in HTML summary report which shows the load results for each thermal zone, and I tried to generate the "Zone Component Load Summary" as well to see the details about load breakdown and choose the right peak load number. But I found the eppy scripts didn't work well to generate the "Zone Component Load Summary" in html report while the EP-Launch made it successfully (They are running the same IDF file). I used to come to some similar situation without setting "run expanded objects" to "True" in Eppy run function, is there any parameter here to generating "Zone Component Load Summary" report as well when running simulation with Eppy? Following are screen shot for report tables run with Eppy and with EP-Launch, the latter one has contained the "Zone Component Load Summary" part for thermalzone "01_C1".

image description image description

But there seems to be not a relevant parameter for generating Zone Component Load Summary report in eppy run() function: image description

EnergyPlus Documentation has some explanation for summary report, but still confused since it seemed that none of “AllSummary” “AllMonthly” “AllSummaryAndMonthly” “AllSummaryAndSizingPeriod”, or “AllSummaryMonthlyAndSizingPeriod” could work with Eppy to generate the Zone Component Load Summary.

edit retag flag offensive close merge delete

Comments

Are you 100% certain eppy and the IDF editor are running the same IDF file, and you're looking at the right HTML output file? I can't think of a single reason why it would be included in one but not the other. Can you share that IDF file and a snippet of your python code (at least your function call to run the simulation)?

Julien Marrec gravatar imageJulien Marrec ( 2018-06-12 01:23:55 -0500 )edit

Julien, thanks for your reply. Unfortunately, yes, I tried 2 different IDFs, but both of them cannot work with eppy. This is the path to the IDF file " fname1 = 'C:\Users\yueyue.zhou\Documents\Intern\ShadeStudy\C1NoShadeAustinIdeal.idf' " And in EP-Launch it's the same one. (Sorry I don't know how to insert images in comment) The call to run : "idf1 = IDF(fname1, epwname)" " idf1.run(output_directory = resultsdir, expandobjects=True)" Link to the IDF: https://drive.google.com/file/d/1d7Aj...

Yueyue_Zhou gravatar imageYueyue_Zhou ( 2018-06-12 11:12:57 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2018-06-12 16:40:07 -0500

Yueyue_Zhou gravatar image

Fortunately, I solved this problem by deleting the "eplusout.expidf" in my result directory before running it again!! When I changed the summary report to "zone component load summary" and ran it again, I didn't delete the result files since most of the them would be overwritten by new result files. But actually, the eplusout.expidf was not regenerated or overwritten every time I reran it and it would overwrite my initial IDF file for the report part. That's the reason why I couldn't generate the report by simply changing the initial IDF file. Hope this would help to someone comes into the similar problems.

edit flag offensive delete link more

Comments

I wonder if this should be treated as a bug in the EnergyPlus command line, rather than a bug in eppy. In any case, can you open an issue at https://github.com/santoshphilip/eppy.... Suggest any potential solutions that you think might work.

santoshphilip gravatar imagesantoshphilip ( 2018-06-13 20:05:18 -0500 )edit

Yeah, You're probably right, this might be a bug in E+ engine, but fixed by EP-Launch. I've tried to run that in EP-Launch for several times with report input changed, it went on well generating the right results.

Yueyue_Zhou gravatar imageYueyue_Zhou ( 2018-06-15 13:32:20 -0500 )edit

I think eppy should solve it the way EP-Launch does it. If you open an issue at https://github.com/santoshphilip/eppy... one of us will take a stab at implementing it.

santoshphilip gravatar imagesantoshphilip ( 2018-06-15 16:41:42 -0500 )edit

Thanks, Santoshphilip, I have opened an issue for this problem. Hope it could be fixed.

Yueyue_Zhou gravatar imageYueyue_Zhou ( 2018-07-06 12:47:09 -0500 )edit

I see it, will fix if possible.

santoshphilip gravatar imagesantoshphilip ( 2018-07-06 13:01:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-06-11 18:59:48 -0500

Seen: 63 times

Last updated: Jun 12