Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

ERROR using Euclid for Sketchup when loading climate file

asked 2018-01-19 12:46:00 -0600

FLECARP gravatar image

updated 2018-01-21 08:05:04 -0600

Hello,

I am using the following the pluggin Euclide for Sketchup to run building energy simulations using Energy Plus. But when I try to load the climate file, the following message appears with Sketchup 2018 and even with Sketchup 2017. Could you help me to solve this?

ERROR:
ArgumentError
invalid byte sequence in UTF-8

BACKTRACE:
C:/Users/F3159470/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/euclid/lib/legacy_openstudio/lib/WeatherFile.rb:33:in `split'
C:/Users/F3159470/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/euclid/lib/legacy_openstudio/lib/WeatherFile.rb:33:in `parse_header'
C:/Users/F3159470/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/euclid/lib/legacy_openstudio/lib/WeatherFile.rb:18:in `initialize'
C:/Users/F3159470/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/euclid/lib/legacy_openstudio/lib/dialogs/RunSimulationDialog.rb:95:in `new'
C:/Users/F3159470/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/euclid/lib/legacy_openstudio/lib/dialogs/RunSimulationDialog.rb:95:in `show_weather_file_info'
C:/Users/F3159470/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/euclid/lib/legacy_openstudio/lib/dialogs/RunSimulationDialog.rb:87:in `on_browse'
C:/Users/F3159470/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/euclid/lib/legacy_openstudio/lib/dialogs/RunSimulationDialog.rb:27:in `block in add_callbacks'
SketchUp:1:in `call'

CONFIGURATION: Euclid 0.9.3 SketchUp 17.2.2555 64-bit Pro Ruby 2.2.4 x64-mingw32

edit retag flag offensive close merge delete

Comments

@FLECARP could you post a link to your climate file (the very one you use)?

Avi gravatar image Avi  ( 2018-01-21 07:45:07 -0600 )edit
FLECARP gravatar image FLECARP  ( 2018-01-21 08:40:19 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-01-21 10:06:27 -0600

Avi gravatar image

As the warning stated this is a problem of the weather file encoding. For some reason the file you are using have different encoding than the one you can find in EnergyPlus site here. I advise you to download again the weather files and make sure not to open and resave them. Also make sure you relanch Euclid after you tried loading the damaged weather file. so you start fresh.

edit flag offensive delete link more
1

answered 2018-01-26 16:31:45 -0600

As Avi mentions, the problem is that there is a bad character encoding in the weather file. This means there is one or more text characters that come from a different/wrong character set (specifically not UTF-8). I tracked it down in your weather file (thanks for providing!) and found it in the first line:

LOCATION,São Paulo,SP,BRA,INMET,837810,-23.85,-46.64,-3.0,792.0

The ã character in São Paulo is the bad one. The easiest fix is to open your weather file in a text editor and change the ã with tilde to a regular a (no tilde). Then save your file and now it should work. Just to be precise, the problem is not the tilde, it's just that the character used is from a different encoding. You can certainly have characters with tildes. They just need to be in the UTF-8 encoding.

Many text editors can also save to a specific encoding. Try doing Save As and then look for an Encoding option. Select UTF-8 for the encoding. This should fix all encoding problems, not just one bad character.

All of that said, programs should generally try to catch encoding problems and handle them gracefully, not crash--this is a bug in Euclid that should be fixed. I have created an issue here to document the bug until it's fixed.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2018-01-19 12:46:00 -0600

Seen: 248 times

Last updated: Jan 26 '18