Openstudio 2.3 won't launch

asked 2017-10-30 15:09:43 -0500

umop-3pisdn gravatar image

updated 2018-04-06 14:36:13 -0500

I've just installed openstudio 2.3, but am not able to launch the app. I can open OSM files in the sketchup plugin (working in sketchup 17) just fine, but whenever i push the "launch openstudio" button, nothing happens. Same thing when I try double-clicking an OSM file (the .osm extension is mapped to openstudio), double-clicki the start menu shortcut, and even when i navigate directly to C:\openstudio-2.3.0\bin and double-click "openstudioapp.exe" or "openstudio.exe".

Poked around the forums, but only found recommendations to try and open the app from the program directory, which isn't working out for me! I've tried restarting/reinstalling, and have removed all old versions of openstudio.

Any ideas?


I was unable to solve this issue without reformatting the laptop. Possible due to a corrupt registry entry - but that's just speculation. All's well that ends well... running 2.5 happily now!

edit retag flag offensive close merge delete

Comments

also - running Windows 7 x64. Tried re-downloading, re-installing, and re-launching w/ windows defender, and all endpoint security/antivirus software disabled - still no dice!

umop-3pisdn gravatar imageumop-3pisdn ( 2017-10-30 16:04:12 -0500 )edit

Is the problem limited to just OpenStudio, i.e., can you open other .exe files? You may want to try rebooting your computer in safe mode to see if any errors pop-up, check your antivirus settings, rerun antivirus scans. It's possibly a registry issue. You may want to backup your files and do a system restore.

mdahlhausen gravatar imagemdahlhausen ( 2017-10-30 17:10:40 -0500 )edit

i can open other executables fine, including the last version of OpenStudio I had (1.14); the problem is isolated to OpenStudio 2.3, and isn't mitigated by disabling UAC, antivirus and Windows Defender - i will try Safe Mode and report back.

umop-3pisdn gravatar imageumop-3pisdn ( 2017-10-31 09:36:37 -0500 )edit

Are there any spaces in the file path? If so try removing them. Double-clicking osm does not load file if file path contains white space

MatthewSteen gravatar imageMatthewSteen ( 2017-10-31 10:09:43 -0500 )edit

am trying to open a local file in a whitespace-free path, so that's not the issue; i also can't open the EXE itself directly from its location in C:\openstudio-2.3.0\bin via windows nor command prompt.

HOWEVER, i just booted in safe mode + networking and am able to open the software and run the simulation fine! does this imply some registry error?

umop-3pisdn gravatar imageumop-3pisdn ( 2017-10-31 10:15:45 -0500 )edit