Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
4

How do I avoid incorrect boundaries when using surface-matching and intersecting measures?

asked 2017-07-20 02:27:47 -0500

pep4life gravatar image

updated 2017-07-21 02:08:54 -0500

Hi, I'm modeling a 2-storey building where level 1 and level 2 have different layouts of spaces (I am using SketchUp Make 2017 and OpenStudio 2.1.0). I've created spaces with the "create spaces from diagram" tool in the plugin (to avoid snapping issues that may result from drawing each space separately with the new space tool). I've tried surface matching, but some floors and walls have incorrect boundary conditions. Reading on a previous post (https://unmethours.com/question/1687/...), I tried using the intersecting and surface matching measures in the OS app instead, and this approach resulted in fewer incorrect boundaries for surfaces; however, still some of the 2nd level floor was ground bound, and some 1st level ceiling and some interior walls were outside bound. Some examples of incorrect boundaries which are (seemingly) correctable when using the Inspector tool: C:\fakepath\Screen Shot 2017-07-19 at 10.46.19 PM.png C:\fakepath\Screen Shot 2017-07-19 at 10.48.46 PM.png C:\fakepath\Screen Shot 2017-07-19 at 10.50.20 PM.png C:\fakepath\Screen Shot 2017-07-19 at 11.56.15 PM.png ("facets")

It seems like I can fix these few problems "by hand" via the "Outside Boundary Condition Object" in the Inspector, as seen on a previous post, but when I try to match an incorrectly labelled exterior wall to another interior wall, although the incorrectly labelled "exterior" surface that I am changing to an interior surface (green surface as per Render by Boundary mode) does in fact turn green, then the surface I am using for the matching sometimes itself turns blue (hinting an exterior surface), even though it still reads as having no sun or wind exposure and indicates that the 2 surfaces are matched. Because of this, I am concerned that the tool may not be correctly adjusting the boundary condition. There are also additional "facets" in the floor plan (presumably resulting from the intersecting tool because the floor layouts are not identical), which each constitute another surface, even though they are part of the same floor in a given space.

Although I don't have any errors or warnings after adjusting the boundary of several surfaces, will I run into errors as I proceed to specify the spaces, thermal zones, and HVAC systems, etc. because of the "facets" and because the surface matching was not a "clean" surface match and I had to make adjustments to boundary condition objects of some of the surfaces "by hand" via the Inspector tool? Is it possible to avoid these intersecting and surface-matching issues? Is each surface drawn double-sided by default, such that even if surface-matching is performed correctly, one side of a wall can still have exterior exposure while the other side is interior? Any suggestions for improvement would be greatly appreciated! Thanks so much!

I am adding the following, after following the suggestions in @rsunnam's answer:

Thank you @rsunnam. I appreciate your suggestions and have spent considerable time redrawing ... (more)

edit retag flag offensive close merge delete

Comments

In your latest screenshot, it appears that two surfaces were created at the same location during intersection (sometimes caused due to slight offset in edges /vertices). Can you try clicking on the edges of the affected surfaces and see if you notice any anomalies? Some times you see multiple lines overlapping that can cause this issue.

rsunnam gravatar imagersunnam ( 2017-07-21 12:21:35 -0500 )edit

Thanks. I've zoomed in to check edges, but can find no slight offsets that imply the presence of what I call "facets" due to the intersection measure adding the annoying extra lines. I've even redrawn ueber carefully using inferencing. I have noticed, though, that the extra "faceted" type lines on the 2nd floor are almost invariably drawn from the top of 1st floor walls to the u/s of 2nd floor walls. I've added the Weld plugin and the Query tool to inspect vertices to 6 decimal places, but even though all vertices for L1 ceiling and L2 floor are at 160", facets still emerge! Please help!!!

pep4life gravatar imagepep4life ( 2017-07-27 16:56:52 -0500 )edit

In my humble opinion you should fist simplificate your model. The detail level shown in your screen shots is remarkable but in most of the cases, the results in a simplified model will not differ significantly while complex models will increase not only execution times but all kind of geometry problems.

I would like to discuss my guidelines:

  • Model spaces should not match real building spaces
  • Real building spaces should be merge into only one model space if their interior/exterior solicitations and HVAC are similar
  • 0.5 m precision is enough for drawing the geomtry
mapascual gravatar imagemapascual ( 2017-08-17 01:22:10 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2017-07-20 14:10:30 -0500

HI @pep4life

I noticed similar issues with a few of my models previously. In my experience, the surface intersect /matching measures work well only when the geometry is very precisely drawn. Snapping to points in Sketchup can get slightly off if enough care isn't taken while drawing and this often results in very small offsets between adjacent surfaces. They are hard to catch but can be noticed when you zoom in really close to the edges. Hence it is very important to pay close attention to snapping in Sketchup when you draw geometry. If I run into similar issues with surface intersection, I usually check for such offsets and redraw these zones/surfaces. Of course, it is tedious and time taking but I can't think of an automated way to correct these manual drawing errors. Did you check to see if all the edges exactly aligned with each other for the surfaces that are having these issues?

If the surface intersection issues are still not resolved after redrawing, the last resort is to take the model to energy plus (or openstudio app) and run it to find the culprit surfaces that would prevent the model from running. This is not the most perfect way of troubleshooting as certain surfaces may remain unmatched but the model might still run. I would suggest doing this only if you are sure that the surfaces that have matching issues are extremely small and you are sure that their impact would be negligible. If your model runs without errors or warnings and you are comfortable with the matching to a reasonable extent, you should be fine. Surface related errors would not be introduced when you add systems, etc.

Hope that helps!

PS: The outside boundary condition of building surface can either be another surface or outdoors (or any of the other options available). This doesn't change based on the which side you are looking at.

edit flag offensive delete link more
2

answered 2017-08-15 17:12:54 -0500

pep4life gravatar image

updated 2018-04-11 14:18:01 -0500

rkbest gravatar image

I wanted to post my own solution to the issues I have encountered in trying to intersect and surface-match my building. The two main problems I encountered are indeed solvable: 1. extra diagonal lines that show up after intersecting; and 2. not all surfaces are assigned correctly.

Starting with 1. : If diagonal lines showed up in my model after using the intersecting/surface-matching measure, I went back and drew my space diagram more carefully and slowly, using sketchup inferencing, snapping, and axis-locking. In the sketchup file, I selected decimal units with a 6-digit accuracy. And I slowed waaaaay down when drawing. I also got the query tool from the sketchup extension warehouse, to help me check all vertices and midpoints for correct z's and to help check for segments of lines (these must be removed, or they create extra, unneeded surfaces and more problems). I also avoided using the protractor for drawing diagonal lines (using it would yield a z of -0.000000 on vertices of lines drawn using it and then extra intersecting diagonal lines would appear after surface matching). I also deleted all guides each time before I applied the surface matching measure. In terms of the room shapes (two floors with completely different space layouts), I avoided "jogs" in geometry as much as possible and tried to simplify the plan to be as orthogonal as possible. After many tries, these tips proved successful and I achieved a model without any extra diagonal lines from using the intersect/surface match measure.

2: If certain interior surfaces were showing as outside-bounded or if second floor surfaces were showing as ground-bounded after having used the Surface Match measure with Intersection option through the OpenStudio application, then I used the Inspector tool in the plugin to manually change the Outside Boundary Condition Object (OBCO) for those problem surfaces. Although I learned about this method in a previous post, it was not clear as to how the surfaces were connected... and so if I needed a second floor surface to change from "ground"- to "surface" -bound, I would find an adjacent "surface"-bound floor to match my faulty surface to. But you will notice that, through the surface match measure, all surfaces already have a matched surface (OBCO) that they are bound to (at least those surfaces on a floor higher than the ground floor), and so in selecting some other adjacent surface with the correct surface boundary, it wreaks havoc on other surfaces in the building ... unless you don't mind playing some "wack-a-mole", you will be solving one problem, only for another to appear somewhere else. However, in using the Filter tool in the plugin, it became apparent how the surfaces are connected! Each "Floor" surface type on the second floor has a corresponding "Roof/Ceiling" surface type, and vice-versa. Use the section cut tool in sketchup and select the problem floor surface... then opening the Inspector tool in the plugin, find the number associated with a given Floor ... (more)

edit flag offensive delete link more

Comments

Glad you were able to fix your issue!

rsunnam gravatar imagersunnam ( 2017-08-16 13:48:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-07-20 02:27:47 -0500

Seen: 507 times

Last updated: Apr 11