Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

SetLightingLoads by LPD measure error

asked 2017-05-07 14:33:14 -0600

antonszilasi gravatar image

updated 2017-05-07 17:13:35 -0600

Dear all,

I am attempting to apply the measure SetLightingLoadsByLPD to my osm model (which I would attach if I could .osm files are not allowed) unfortunately I receive the following error.

image description

I would attempt to debug it myself except that after updating to OpenStudio 2.1.0 ruby has stopped working on my machine, which I have asked as another question here.

Any help and pointers would be greatly appreciated! Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-05-08 11:31:59 -0600

This is happening because the measure is not setup to run on space types that don't have any lights objects, as it uses existing light objects to create schedule for new lights object. We can update it in the future to be more robust, but for now if you put a lights object in the space type of the baseline model it should work fine. Make sure the light either has a schedule or inherits a schedule from a schedule set. We can update this to be more robust to add the light, but not attempt to set a schedule, if there was not a light in the space to start with.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-05-07 14:33:14 -0600

Seen: 56 times

Last updated: May 08 '17