Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Upgraded to OpenStudio 2.1.0 ruby has stopped working

asked 2017-05-07 14:29:49 -0600

antonszilasi gravatar image

updated 2017-05-07 17:12:45 -0600

Dear all,

I recently uninstalled OpenStudio V1.1.3 and have upgraded to V2.1, now when I type ruby into my cmd window it is no longer recognized as an internal or external command.

In my environment variables my path variables for the ruby bin folder is correct furthermore I updated the .rb file under: C:\Ruby200-x64\lib\ruby\site_ruby to the following which is the correct path for openstudio.

What else am I missing here? Many thanks!

image description

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2017-05-07 17:32:56 -0600

updated 2017-05-07 20:25:41 -0600

OpenStudio 2.0.0 was the last version to use Ruby 2.0.

Try updating Ruby to 2.2.4 to use the bindings with OpenStudio >= 2.0.1.

edit flag offensive delete link more
0

answered 2017-05-08 01:42:13 -0600

Funky gravatar image

Hi, I also have the same issue with Ruby 2.3.3 (x64).

edit flag offensive delete link more

Comments

@Funky, this is not an answer, please delete and use the add a comment feature.

MatthewSteen gravatar imageMatthewSteen ( 2017-05-08 10:22:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-05-07 14:29:49 -0600

Seen: 78 times

Last updated: May 07 '17