Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

Construction Name is required but was blank

asked 2017-04-04 07:56:17 -0500

PaoloMassaroni gravatar image

updated 2017-05-05 19:16:19 -0500

The problem it's that even following other people's advice i still have all my building surfaces without a construction name. I had created a construction set with all the types of constructions in Open Studio. Then i selected the whole model also in SketchUp Plug-in to set my "construction set" using the "Set Attributes Tool". I tried also to use the measure "Remove Orphan Subsurfaces plugin" , but nothing. I cheked also if the model has glass doors, but it's not that problem. So the funny thing it's that only fixed windows has the correct construction name. Other surfaces have everything in theyr places (name, surface type, outside boundary condition) except construction name. How can I fix this problem?

edit retag flag offensive close merge delete

Comments

Are you getting missing construction errors for all surfaces (except windows) or just a subset of surfaces? Also are you using adiabatic boundary condition anywhere?

David Goldwasser gravatar image David Goldwasser  ( 2017-04-04 08:27:36 -0500 )edit

It's for all the surfaces. I used adiabatic boundary just for a few surfaces which have same problem.

PaoloMassaroni gravatar image PaoloMassaroni  ( 2017-04-04 08:44:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-04-04 09:53:23 -0500

Open your OSM with the OpenStudio application and see that your construction set looks similar to the example in the documentation.

You can then apply that construction set to the entire building, a building story, a space type, or individual spaces. It sounds like you tried the last approach (spaces). That should look like this, but would would have it applied to every space.

image description

If you want the same construction set used everywhere the most direct way would be instead to apply it directly to the building object, which would look like this.

image description

With either approach if you look at surfaces you should see most construction names in green (these are inherited vs. hard assigned.)

image description

Notice that the adiabatic surface in my example doesn't have a green construction. That is because our default construction set is only setup to handle ground, interior, and exterior boundary conditions. There is a feature request to extend it for adiabatic, but for now you have to hard assign constructions to adiabatic surfaces. You can do that manually, in the app this is done by dragging a construction from "My Model" or "Library" to the dropbox for the surface. There is also a user script in the SketchUp plugin to set selected surfaces to adiabatic and assign a construction.

edit flag offensive delete link more

Comments

OK, now seems it works!Really thank you!Just one thing, even if the simulation doesn't show problems, in the sketchup plug-in surfaces still doesn't have a connection with the construction name. Anyway it's ok

PaoloMassaroni gravatar image PaoloMassaroni  ( 2017-04-05 10:22:03 -0500 )edit

The OS APP shows inherited constructions but the SketchUp Plugin inspector does not; however render by construction in the SketchUp plugin does show them, and if you select a surface it will show you that construction object.

David Goldwasser gravatar image David Goldwasser  ( 2017-04-05 11:47:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2017-04-04 07:56:17 -0500

Seen: 470 times

Last updated: Apr 04 '17