Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
1

How does one set minimum water flow rates through WAHPs?

asked 2016-10-24 15:40:02 -0500

DW gravatar image

updated 2016-10-25 08:02:31 -0500

I have been recieving warnings on my plant loop temperatures getting far too hot and too cold. I have spent some time diagnosing my runaway plant temperatures. I have set my pumps controls in my EnergyPlus model to intermittent and I have tracked all of my node and temperature flows based on the questions here and here. I also see that someone has a similar question here.

I have found that the reason I am getting these temperature errors in my model is because there are a few periods when my WAHPs have very tiny flows through them, and so they raise the water temperature at those nodes tremendously. However, since the flow fraction through these branches is so small, my overall loop temperature stays within my dual setpoint schedule. I have three WAHPs and five WWHPs all sharing the same central plant loop with an autosized boiler and autosized cooling tower (EvaporativeFluidCooler:TwoSpeed). I want to find a way to stop this overheating and overcooling during times of very small flow through these individual water to air heat pumps. Does anyone know of a way to do this?

I tried setting minimum flows in my central loop, but this does not help, because there are bypass branches on both the supply and demand side of my loop. I have been trying to find a way to set minimum flows through only my WAHP branches, but haven't figured out how to do this yet. I have no issues with the operation for my water-to-water heat pumps, only my water to air heat pumps. Any advice is appreciated.

edit retag flag offensive close merge delete

Comments

Which WAHP model are you using? Have you tried using heat transfer pipes, e.g. Pipe:Indoor?

Archmage gravatar image Archmage  ( 2016-10-24 16:01:32 -0500 )edit

I am using AirLoopHVAC:UnitaryHeatPump:WaterToAir objects with equation fit coils: Coil:Heating:WaterToAirHeatPump:EquationFit and Coil:Cooling:WaterToAirHeatPump:EquationFit. I have been using only pipe:Adiabatic types. I will try running with Pipe:Indoor objects now and see if that has any effect. Thank you for the reply!

DW gravatar image DW  ( 2016-10-24 16:15:20 -0500 )edit

Unfortunately @Archmage that did not seem to have an effect. I replaced all 30 pipes with the Pipe:Indoor object in my model, but I still have very extreme temperatures at my WAHP coils at times of very low flow. Do you have any other suggestions of things to try?

DW gravatar image DW  ( 2016-10-26 11:00:43 -0500 )edit

This was corrected in V8.6 for WAHP using cycling water flow. See 5691

rraustad gravatar image rraustad  ( 2016-10-26 11:38:53 -0500 )edit

@rraustad I am using V8.6 I have my max cycling rate set at 2.5 cycles/hour. I am using the default numbers for my coefficients for Coil:Heating/Cooling:WaterToAirHeatPump:EquationFitfrom the InputOutput reference. Is there one of these values that I should change?

DW gravatar image DW  ( 2016-10-26 12:11:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-10-27 08:07:06 -0500

I stand corrected from my comment above. The AirLoopHVAC:UnitaryHeatPump:WaterToAir object can model cycling water-side flow rate. However, the model fails to account for this after the model sets the water flow rate and on subsequent iterations fails to set the water flow rate back up to design to model the coil. Might be TMI here, but that's what's happening.

In your input file, set the last input for Heat Pump Coil Water Flow Mode to Constant or ConstantOnDemand. Your AHUs don't have this input and it defaults to Cycling.

AirLoopHVAC:UnitaryHeatPump:WaterToAir,
  rtu2,                    !- Name
  availability_tbd,        !- Availability Schedule Name
  rtu2 Mixed Air Node,     !- Air Inlet Node Name
  rtu2 Air Loop Outlet Node,  !- Air Outlet Node Name
  0.94389,                 !- Supply Air Flow Rate {m3/s}
  Thermal Zone: Copy_Room, !- Controlling Zone or Thermostat Location
  Fan:OnOff,               !- Supply Air Fan Object Type
  rtu2 fan,                !- Supply Air Fan Name
  Coil:Heating:WaterToAirHeatPump:EquationFit,  !- Heating Coil Object Type
  rtu2 htg coil,           !- Heating Coil Name
  0.001,                   !- Heating Convergence
  Coil:Cooling:WaterToAirHeatPump:EquationFit,  !- Cooling Coil Object Type
  rtu2 clg coil,           !- Cooling Coil Name
  0.001,                   !- Cooling Convergence
  2.5,                     !- Maximum Cycling Rate {cycles/hr}
  60,                      !- Heat Pump Time Constant {s}
  0.01,                    !- Fraction of On-Cycle Power Use
  60,                      !- Heat Pump Fan Delay Time {s}
  Coil:Heating:Fuel,       !- Supplemental Heating Coil Object Type
  rtu2 supp htg coil,      !- Supplemental Heating Coil Name
  50,                      !- Maximum Supply Air Temperature from Supplemental Heater {C}
  21,                      !- Maximum Outdoor Dry-Bulb Temperature for Supplemental Heater Operation {C}
  rtu2 Outside Air Inlet Node,  !- Outdoor Dry-Bulb Temperature Sensor Node Name
  BlowThrough,             !- Fan Placement 
  always off;              !- Supply Air Fan Operating Mode Schedule Name

Add this to the end of this and other objects like this (and also change the semi-colon on the last input above to a comma):

  ,                 !- Dehumidification Control Type
  Constant;    !- Heat Pump Coil Water Flow Mode

VERY IMPORTANT....you must change always off; to always off,

edit flag offensive delete link more

Comments

I found something else strange on the water side of the model. The water enthalpy does not make sense to me and changing to constant flow mode may not make any difference. What I think is happening is the water enthalpy is being calculated as negative, and outside this model the enthalpy is used to back calculate water temperature leading to nonsense values.

rraustad gravatar image rraustad  ( 2016-10-27 13:57:31 -0500 )edit

Thank you very much for looking into this. Changing the unitary objects to constant speed seemed to eliminate my out of range temperature errors for now - at least I no longer see the warnings. I really appreciate your time on this.

DW gravatar image DW  ( 2016-10-28 12:03:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2016-10-24 15:40:02 -0500

Seen: 345 times

Last updated: Oct 27 '16