Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
4

Shading not being applied

asked 2016-08-03 15:37:29 -0500

updated 2016-08-03 15:46:19 -0500

Hi.

I am looking for a tutorial/info/posts on fixed site/building/space shading. This is a very basic question because this is my first OS model and so far I am not able to get the shades in my model to work (i.e. some shades are applied to the building and some are applied to spaces but none have any impact (deleting the shades has the same result).

I suspect the problem is something to do with schedules or transmittance settings (which I am still learning about also) but I haven't yet found guidance.

Thanks, Paul

edit retag flag offensive close merge delete

Comments

1

Are the shading devices showing up as purple in your model? Or are they white? If they are white, they are not part of the OpenStudio model, they are just SketchUp surfaces.

__AmirRoth__ gravatar image __AmirRoth__  ( 2016-08-03 15:52:04 -0500 )edit

Thanks. Shades are purple on building and blue in group. These are simple fixed permanent shading overhangs. I think I have the basics correct from the tutorials etc; so am after more detailed tutorials etc on shading setup. I thought just placing the shades in shading groups in Sketchup would work, but they have no effect. I believe the problem is my setup in OS rather than Sketchup (perhaps scheduling or transmittance). I read the error file prior to my first post and it said shades were always transparent so I amended models and no such error now but still no effect. Regards, Paul

Paul Graham gravatar image Paul Graham  ( 2016-08-04 19:40:47 -0500 )edit

Try reporting fraction sunlit for the surfaces that are supposed to be shaded.

David Goldwasser gravatar image David Goldwasser  ( 2016-08-07 08:45:08 -0500 )edit

Thanks David. I cant see how to report fraction sunlit. The main zone and shade in my model only has East glass and I reported "zone windows total trans'd solar radiation". This indicates no shading in the model (solar indicates sun on windows from sunrise to noon but hand calc shows no sun on windows after 10am), also energy is same if shades are in the model or deleted. I tried various transmitance schedules; using on(1)/off(0) trans schedule (for example) there is a tiny difference - this indicates to me that it is likely transmittance is the problem. However, I cant find how to fix this.

Paul Graham gravatar image Paul Graham  ( 2016-08-07 23:17:37 -0500 )edit

I might have to see the file. Are you trying to do something with a transmission schedule? If you want it be opaque all of the time, you don't need to associate a schedule with a shading surface. Another possible cause would be if the shading surface was inverted, but that shouldn't typically be an issue since (unless you are adding PV) since EnergyPlus mirrors shading surface by default, unless you disabled that.

David Goldwasser gravatar image David Goldwasser  ( 2016-08-08 08:58:00 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
4

answered 2016-08-14 17:48:03 -0500

TomB gravatar image

updated 2016-08-14 23:34:50 -0500

The EnergyPlus Results Report includes a Shading Summary image description

OpenStudio doesn't write the shading objects in the same way that Design Builder does. I recall looking through a DB file and finding a Shading Schedule for every shading surface.

You can convince yourself of that by looking at the out.idf in the sub directory of your working folder. e.g. ..\Your model folder\run\4-EnergyPlusPreProcess-0\out.idf

The Shading Report is a direct way of checking the effect of shading. (Annual) Energy consumption and or cross checking with hand calculations may not be precise enough to conclude that the Shading in your model is ineffective.

shading-report-1.PNG

Perhaps also look at the few other Output variables

  • Zone Exterior Windows Total Transmitted Beam Solar Radiation Energy
  • Output:Variable,*,Surface Outside Face Sunlit Area,hourly; !- Zone Average [m2]
  • Output:Variable,*,Surface Outside Face Sunlit Fraction,hourly; !- Zone Average []

These links and resources took a bit of googling to find; - Look at the 'Add Output Variables' measure described here http://nrel.github.io/OpenStudio-user... - Downloading and applying measures is actually quite easy, despite the hoops to jump through when getting started, https://bcl.nrel.gov/node/37843

edit flag offensive delete link more
0

answered 2017-03-03 12:58:11 -0500

Gjko gravatar image

I have the same problem here. In the EnergyPlus Results Report the Surface Shadowing Summary shows the shading surfaces and the Possible Shadow Receivers, while Shading Summary shows none Sunlit Fraction.

It seem fixed by changing the number of timesteps per Hour to 6.

edit flag offensive delete link more
0

answered 2019-06-21 03:46:45 -0500

Ngoni gravatar image

I also had the same problem. Answer: Go to E+ IDF editor, under simulation parameters go to building/solar distribution and set to FullInteriorAndExterior Mine was set to MinimalShadowing which only calculates shadowing for reveals. (refer to EnergyPlus OutputInput Reference document, item 1.4.4.1.7 Field: Solar Distribution on page 41). I am yet to verify but i am hoping this will also solve the problem i had of change glazing material type not having any effect.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

3 followers

Stats

Asked: 2016-08-03 15:37:29 -0500

Seen: 943 times

Last updated: Mar 03 '17