Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Operative temperature in .csv file doesn't match with .sql file

asked 2016-06-16 08:51:32 -0500

AylaZiger gravatar image

updated 2016-06-17 10:02:36 -0500

I have my simulation results, i also have exported them to excel with ReadVarsESO.exe. When I open the .sql file on the Results Viewer, the operative temperature variates from 34 to 14°C, but when I open the .csv file in excel, the result appear with 16 numbers. For example, in ResulstsViewer the operative temperature is 21,9°C, but in excel is 219575258579145. How do I fix it?

English is not my first language, sorry for any mistake.

Edit: image description

edit retag flag offensive close merge delete

Comments

Divide by 1E13?

Julien Marrec gravatar imageJulien Marrec ( 2016-06-17 05:17:33 -0500 )edit

@AylaZiger, you are much better at English than I am at your native language, or any other language for that matter. No need to apologize.

__AmirRoth__ gravatar image__AmirRoth__ ( 2016-06-17 10:03:58 -0500 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2016-06-17 08:52:36 -0500

Archmage gravatar image

I would guess that there is an issue with using "," instead of "." for the decimal point inside Excel. Using the US practice, the value would be 21.9C, not 21,9C. When Excel is in comma-for-decimal mode, it has a hard time reading in comma-separated-values (CSV), because it doesn't know that a comma is a delimiter between values.

edit flag offensive delete link more

Comments

That would be easy to check too: if your resulting table has cells with no value towards the right columns, that's probably it. One way to define the import settings is to open a new workbook, go to Data > Import, select the csv file, and then specify that it is "Delimited" and pick the comma as a separator.

Julien Marrec gravatar imageJulien Marrec ( 2016-06-18 03:09:07 -0500 )edit

When I open the csv file, all the results appear in just one column, cause my excel are in portuguese. Then I go to Data > Text to columns to specify comma as separator, and the spread sheet change to columns like the image I posted.

AylaZiger gravatar imageAylaZiger ( 2016-06-20 06:51:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2016-06-16 08:51:32 -0500

Seen: 85 times

Last updated: Jun 22 '16