Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

Running Simulation without HVAC

asked 2014-12-04 08:01:31 -0500

jeff.lee812's avatar

updated 2015-01-09 12:36:16 -0500


I'm trying to run my model without any HVAC (basically just a house sitting out in the environment). However when I try to run my simulation, it seems that i'm getting errors about my thermostats. I may have tinkered with them. How do I get around this error? (I basically want to know how I can run the model w/o having to deal with people or thermostat schedules)

Error reads like:

* ThermostatSetpoint:DualSetpoint="THERMOSTAT SETPOINT DUAL SETPOINT 4" invalid Heating Setpoint Temperature Schedule Name="" not found. * Severe * ThermostatSetpoint:DualSetpoint="THERMOSTAT SETPOINT DUAL SETPOINT 4" invalid Cooling Setpoint Temperature Schedule Name="" not found. * Severe * GetStagedDualSetpoint: Errors with invalid names in ZoneControl:Thermostat:StagedDualSetpoint objects. * ~~~ * ...These will not be read in. Other errors may occur. * Fatal ** Errors getting Zone Control input data. Preceding condition(s) cause termination. ...Summary of Errors that led to program termination: ..... Reference severe error count=7 ..... Last severe error=GetStagedDualSetpoint: Errors with invalid names in ZoneControl:Thermostat:StagedDualSetpoint objects.


edit retag flag offensive close merge delete


In my opinion this is the major problem with EnergyPlus. You can't really simulate anything in isolation, so instead of "debugging" subsystem by subsystem you have to simulate the whole building and hope there are no major errors. Poor design choice, but especially a problem when you're trying to calibrate subsystems to real data.

Sam's avatar Sam  ( 2014-12-18 22:05:21 -0500 )edit

@Sam This comment isn't relevant to the question. EnergyPlus is capable of simulating unconditioned spaces with no HVAC equipment and no internal gains. This question relates to using the interface correctly to set that up.

MJWitte's avatar MJWitte  ( 2014-12-19 11:06:15 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2014-12-04 08:13:17 -0500

scottb's avatar


If you want to do a free floating temperature analysis you should remove all thermostats and related schedules and HVAC.

It would seem that you still have ' ThermostatSetpoint:DualSetpoint' objects defined in your IDF.

That should do the trick,


edit flag offensive delete link more

answered 2014-12-04 08:48:01 -0500

updated 2014-12-16 08:15:26 -0500

Taking a step back, I don't think you can successfully run a model with thermostats but without HVAC systems. You can turn on ideal air loads for all zones which should deactivate any thermostat schedules associated with the zone and eliminate the error.

If your model has a lot of zones you can use the measure Enable Ideal Air Loads For All Zones to loop through all the zones and do this for you. I do this to check for geometry errors before adding HVAC systems.

edit flag offensive delete link more


Matt, I think a zone can have a thermostat that doesn't have any equipment or ideal air loads serving it. It just won't meet it's setpoint, but I think it runs fine.

David Goldwasser's avatar David Goldwasser  ( 2014-12-04 11:08:20 -0500 )edit

You're right David, I just ran a quick test. I also looked at the Time Setpoint Not Met results which showed zero hours for cooling and heating.

MatthewSteen's avatar MatthewSteen  ( 2014-12-04 11:37:38 -0500 )edit

answered 2014-12-04 08:21:19 -0500

The thermostat should have both a heating and cooling schedule. If you delete the thermostat the error should go away.

Normally the OpenStudio app should delete the thermostat associated with a zone if the schedules are removed.I'm wondering if that didnt happen in your case?

The easiest way to delete this thermostat if you can't see it in the stand alone app is to open the model in SketchUp plugin and open the inspector (looks like magnifying glass with OS icon in it).

We do have some unused thermostats in our templates but I think they are all valid.

edit flag offensive delete link more


hi, how can I remove the set point schedule that I have assigned to a thermal zone?

Antop's avatar Antop  ( 2014-12-13 06:34:37 -0500 )edit

You can remove a schedule setpoint on a thermostat in two ways.

  1. Drag another schedule on to replace the current one
  2. Turn off the thermostat. In this case the thermostat object will be thrown away.

In either case the schedule isn't removed from the model, but just not assign to the thermostat anymore.

David Goldwasser's avatar David Goldwasser  ( 2014-12-14 23:44:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-12-04 08:01:31 -0500

Seen: 1,424 times

Last updated: Dec 16 '14