Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
2

Turn off AirLoopHVACUnitarySystem at night but with a Night Cycle control

asked 2016-05-12 14:13:41 -0600

I'm trying to shut down my airloops at night, but to have an AvailabilityManager:NightCycle to turn them back on if the temperature drifts too far. I want to turn them off from 6PM to 8AM the next day, so I've created a schedule that I'll call hvac_op_sch in the following, with 1 for daytime and 0 for nighttime.

Usually that works out very well, but in this case I'm using AirLoopHVACUnitarySystem and cannot figure out how to do it.

I have multiple air loops that are working with 100% during daytime (and a lot of flow too!) and nothing at night. They look like the following:

AirLoop with UnitarySystem

Here's my setup:

  • AirLoopHVACOutdoorAirSystem:

    • I've set the Minimum Outdoor Air Schedule Name to be my hvac_op_sch. That triggers an AvailabilityManager:Scheduled for the Outdoor Air System.
    • I've hard sized the Minimum Outdoor Air Flow Rate and the Maximum Outdoor Air Flow rate to my design flow rate and set the Minimum and Maximum Fraction of Outdoor Air Schedule Name to be Always 1.
  • AirLoopHVAC: I've set an AvailabilityManager:NightCycle to have the hvac_op_sch

  • AirLoopHVACUnitarySystem:

    • For the record it has a Fan:ConstantVolume, a WaterToAir heating and cooling coils.
    • I've set the Supply Air Fan Operating Mode Schedule Name to Always_1, otherwise the outside air was cycling with the system during the daytime.
    • I've tried setting the Availability Schedule to both Always_1 and hvac_op_sch
    • If Always_1: the flow continues even at night, which leads to much higher energy consumption than needed. The AvailabilityManager:NightCycle has no effect ** whatsoever!
    • If hvac_op_sch: everything shuts down at night, but the AvailabilityManager:NightCycle again has no effect and won't turn the system back on and I end up with a ton of unmet hours.

How can I have this system behave like a regular airLoopHVAC and have the AvailabilityManager:NightCycle do its job?

edit retag flag offensive close merge delete

Comments

@rraustad any ideas here? Julien and I talked about this offline, but I didn't have any suggestions.

Kyle Benne gravatar image Kyle Benne  ( 2016-05-13 10:29:14 -0600 )edit

The availability managers override the fan operation. If the fan is always on, the availability managers will have no affect. This line at 10833 of HVACUnitarySystem is how the fan is overridden by avail managers.

if ( GetCurrentScheduleValue( UnitarySystem( UnitarySysNum ).SysAvailSchedPtr ) > 0.0 && ( ( FanOn || TurnFansOn ) && ! TurnFansOff ) ) {
rraustad gravatar image rraustad  ( 2016-05-13 11:31:08 -0600 )edit

"AirLoopHVAC: I've set an AvailabilityManager:NightCycle to have the hvac_op_sch"

Are you saying here that the night cycle manager value = 0 at night?

rraustad gravatar image rraustad  ( 2016-05-13 11:35:58 -0600 )edit

That's what I'm saying yes. I'm reading the doc right now, I see that it's supposed to be the opposite, 1 for off, 0 for on. Weirdly enough, I think I've always done it this way and it worked. I'm confused.

Julien Marrec gravatar image Julien Marrec  ( 2016-05-13 11:50:08 -0600 )edit

I got confused because I didn't really know what OpenStudio was doing during forward translation: I would set the fan availability schedule to Always On Discrete and set the "Time of Operation - HVAC Operation Schedule" to be my hvac_op_sch (that's actually the airloop availability schedule)

I end up with a proper availabilitymanager:NightCycle: The applicability schedule is "Always On Discrete" (that's hard coded), and the Fan Schedule Name, which is the same as my Fan Availability Schedule, comes from the airloop availability sch (hvac_op_sch, 1 during day, zero during night)

Julien Marrec gravatar image Julien Marrec  ( 2016-05-30 04:32:09 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-12 15:26:31 -0600

In the end I've basically tried every possible combination, and I got it to work.

I assigned hvac_op_sch to the AirLoopHVACOutdoorAirSystem's Minimum and Maximum Fraction of Outdoor Air Schedule Name as well, and now it works... Not sure if I needed to assign it to both.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2016-05-12 14:13:41 -0600

Seen: 245 times

Last updated: May 12 '16