Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
4

rcontrib misses one of the modifiers if number of modifiers between 240-420

asked 2016-05-10 01:34:54 -0600

updated 2016-05-10 01:36:27 -0600

I'm using rcontrib to calculate number of sunlighthours for a grid of test points. With the help of @Andyrew on this previous question I'm getting accurate results as far as the number of modifiers (suns) is less then or equal to 239.

If I create between 240-420 modifiers rcontrib will generate the results for n-1 of the modifiers (239-419). You can test the this file to recreate the issue. The file is a zipped file but I had to change the extension to tiff to be able to upload it! If you unzip the file and check untitled.dc file NCOLS is 239 however number of modifiers in untitled_suns.rad is 240.

If I create more than 420 modifiers the number of columns in result file will be accurate but one of the modifiers won't be seen by the test points. In the image below you can see the area that are missing the same modifier. The rest of the points return accurate value as they are already blocked by the wall.

image description

edit retag flag offensive close merge delete

Comments

1

I just ran your test case on OSX, and got 240 columns. Every column (sun) has at least one non-zero value. I noticed with all your files there isn't newline before the end of the files. On some systems, with some tools, and some files, I find that I need an extra line feed at the end of a file to make everything work as expected. I don't fully understand why, but a newline at the end of a text file is a Unix standard, the lack of a newline sometimes cause the last line to be ignored. So maybe try that? In the meantime I'll tartup my virtual PC and install Radiance and all that to test on a PC.

Andyrew gravatar imageAndyrew ( 2016-05-10 11:19:51 -0600 )edit

Extra line at the end changes the results. Now I get 240 columns too. I will do more tests and close this discussion if I couldn't recreate the issue. Thanks!

Mostapha Roudsari gravatar imageMostapha Roudsari ( 2016-05-10 15:35:17 -0600 )edit

Hi @Andyrew, Adding an extra line solved the issue with the number of columns but I can still create an invisible modifier. You can download the files from here. If you check columns for modifier 1217 (columns EJI, EJJ and EJK in excel) you will see that the sum of the values is equal to 0 which means none of the test points (each row is the results for one of the test points) can see the modifier. If you can't recreate the issue on your machine then it's probably a Windows specific issue. Thanks for your help!

Mostapha Roudsari gravatar imageMostapha Roudsari ( 2016-05-10 18:52:19 -0600 )edit

3 Answers

Sort by » oldest newest most voted
3

answered 2016-05-13 08:56:49 -0600

As discussed on radiance-dev: Greg has already upped the limit on the number of modifiers that can be processed at a time. I just fixed a bug today that only showed itself on Windows and could garble some of the modifier names. The changes are in CVS and will be in the HEAD release tomorrow, and in the NREL binaries as soon as Rob gets around to making a fresh package.

-schorsch

edit flag offensive delete link more
3

answered 2016-05-13 16:48:22 -0600

Just for clarification for later reference. This discussion end up being two different discussions which both only happens on Windows.

For original question, missing modifier between 240-420, I needed to add an empty new line at the end of all input files.

The second question, missing modifier solar1216 was a bug in Radiance on Windows which is now fixed and will work fine in newer released of Radiance.

edit flag offensive delete link more

Comments

Technically, you should not need to add an end-of-line character to the end of your file. This may have been a different manifestation of the same bug Schorsch fixed. You should try it again.

GregWard gravatar imageGregWard ( 2016-05-13 17:17:52 -0600 )edit

Hi Greg. Just checked again and I still need end-of-line character to get all the modifiers on Windows. I will wait for the new build of Radiance to run another test and will report back here.

Mostapha Roudsari gravatar imageMostapha Roudsari ( 2016-05-16 20:45:51 -0600 )edit

UPDATE: The issue is solved now. Download version 5.0.1.11.

Mostapha Roudsari gravatar imageMostapha Roudsari ( 2016-05-24 18:06:15 -0600 )edit
2

answered 2016-05-11 00:26:36 -0600

updated 2016-05-11 10:24:40 -0600

It seems like the modifiers you are saying are invisible correspond to suns that are really low in the sky. At first, I thought it might be some issue with low-angled sources getting rejected, but I pored over the code and couldn't find where that might be happening, so I retested your model without any building geometry. I just put the suns together with your test points in rcontrib and ran it again so that nothing gets in the way of the shadow tests. This time, all the DC columns summed to some non-zero value. I concluded that some of the suns are not in line-of-sight and are unlikely to be found by the default single-bounce calculation.

Am I missing something? -Greg

edit flag offensive delete link more

Comments

Hi @GregWard! Thank you for checking the file. I'm using the last release. I ran the analysis for only one test point and no geometry and I still get 0 values for solar1216. If I run the analysis only for solar1216 it's visible. Something is happening when I add to number of modifiers. Maybe it only happens on Windows! We need one more Windows user to test this. @rpg777 and @Sarith any chance that you can test this file on Windows and share the results? Thanks :)

Mostapha Roudsari gravatar imageMostapha Roudsari ( 2016-05-11 06:58:37 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

1 follower

Stats

Asked: 2016-05-10 01:34:54 -0600

Seen: 457 times

Last updated: May 13 '16