Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

How can I fix "Zone has no surfaces" error in Openstudio?

asked 2016-03-18 18:34:41 -0600

updated 2016-03-18 18:37:00 -0600

I made two simple cube (they were adjacent) in Opnestudio then I deleted one of them by delete option in edit menu of the main SketchUp window. At the end when I ran my simulation I got this error:

* Severe * GetSurfaceData: Zone has no surfaces, Zone=THERMAL ZONE 2 * Warning * GetSurfaceData: The total number of floors, walls, roofs and internal mass surfaces in Zone THERMAL ZONE 1

And now I would like to know that how can I fix this error? I have applied the measure of Remove Orphan Objects and Unused Resources but it did not fix it. And I have read this page as well. Does anyone can please help me?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-03-21 13:56:15 -0600

coastalconcepts gravatar image

Or you can open the .OSM file with a text editor, look for "Thermal Zone 2" and delete the paragraph that you find it in.

Then save and run the simulation again.

edit flag offensive delete link more

Comments

@coastalconcepts ,I am really curious about your solution, in fact I tested by removing the yellow lines that are highlighted in the picture but unfortunately when I ran the simulation it again showed previous errors. I have attached my text editor file here and could you please fix it for me, I would like to see how it works. I am really excited to test it and would like to see the result. image description

4Designer gravatar image 4Designer  ( 2016-03-22 07:44:45 -0600 )edit

@coastalconcepts ,This is the link to access the text editor file https://drive.google.com/open?id=0B3D...

4Designer gravatar image 4Designer  ( 2016-03-22 08:19:33 -0600 )edit
1

You're trying to edit the error file itself. You need to edit the actual .OSM file with a text editor

coastalconcepts gravatar image coastalconcepts  ( 2016-03-22 13:55:29 -0600 )edit

@coastalconcepts , Would you please tell me how can I edit the actual .OSM file with a text editor? do you have any links for more information?(for example in your initial comment how can I open the .OSM file with a text editor, looking for "Thermal Zone 2" and deleting the paragraph that I find it in?) thanks in advance for your guidance.

4Designer gravatar image 4Designer  ( 2016-03-25 04:32:12 -0600 )edit
1
  1. Download and install a great text editor like notepad ++: https://notepad-plus-plus.org/download/v6.9.html
    1. Right click on the Openstudio (.OSM) file in question
    2. Open With: Notepad++
    3. Press control+F to open the search functionality
    4. Type in "Thermal Zone 2"
    5. If it shows Thermal Zone 200 or something else keep clicking "find next" until it shows you "Thermal Zone 2"
    6. Highlight the paragraph that contains "Thermal Zone 2" and delete it by hitting backspace
    7. Press ctrl+S to save your file then run it again
coastalconcepts gravatar image coastalconcepts  ( 2016-03-25 05:46:44 -0600 )edit
4

answered 2016-03-19 10:12:30 -0600

Morteza gravatar image

You have to delete the thermal zone that was attached to the deleted cube. You can use "Remove Unused ThermalZone". C:\fakepath\Remove unused thermal zone.jpg

edit flag offensive delete link more

Comments

@Morteza, Thank you Morteza I tested and it worked.

4Designer gravatar image 4Designer  ( 2016-03-22 06:26:46 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

1 follower

Stats

Asked: 2016-03-18 18:34:41 -0600

Seen: 1,054 times

Last updated: Apr 03 '16