Question-and-Answer Resource for the Building Energy Modeling Community
Get s tarted with the Help page
Ask Your Question
3

Surface does not exist error

asked 2015-11-01 18:39:32 -0500

VictoriaEagen gravatar image

updated 2015-11-01 20:18:59 -0500

I am trying to model a dorm in Sketchup/OpenStudio, and I got the first two floors done. Now, when I open my OSM I get hundreds of errors, "Surface # : The space referenced by this surface does not exist, it cannot be drawn". I have only seen one other question similar to this and it required digging into code and deleting the surface. I am a student, and not to savvy with opening script files and sifting through them. Does anyone know if these errors can be ignored? Or how to get rid of them? I tried running a diagnostics thing and deleting the surfaces, but nothing got deleted and they still pop up. Any information on how to get rid of these, or if I can ignore them, would be awesome! Thanks!

edit retag flag offensive close merge delete

Comments

What portion of your model is rendered in SketchUp? Are the majority of spaces missing or just one or two? Do you know what happened that caused these spaces to go missing? I am not aware of any way to create orphan surfaces through the GUIs (although it might now be possible in grid view). Did you edit the text files by hand?

macumber gravatar image macumber  ( 2015-11-02 10:20:44 -0500 )edit

I just confirmed that orphaned surfaces do not show up in grid view in the OpenStudio Application so there is no way to repair these surfaces using that.

macumber gravatar image macumber  ( 2015-11-02 10:34:55 -0500 )edit

It is only one surface. I don't know how to get rid of it. I do not know what to do about it.

VictoriaEagen gravatar image VictoriaEagen  ( 2015-11-02 11:41:44 -0500 )edit

Did you happen to use the SketchUp undo command while working on your model? OpenStudio does not track SketchUp's undo command well so this is a likely cause of any model corruption.

macumber gravatar image macumber  ( 2015-11-04 11:17:29 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2015-11-02 11:54:41 -0500

updated 2015-11-02 15:28:50 -0500

You can run the remove orphan an unused objects measure form the OpenStudio application "Apply Measures Now" or the diagnostic user script in the SketchUp plugin to clean up orphan objects.

Both methods are documented on our troubleshooting page.

edit flag offensive delete link more

Comments

I will try the remove orphan an unused objects measures, but the diagnostics user script does not work. Thank you for the help!

VictoriaEagen gravatar image VictoriaEagen  ( 2015-11-02 14:40:07 -0500 )edit

Ahhh that did not seem to work either, I went to OpenStudio Scripts --> Alter or Add Elements --> Remove Orphan Subsurfaces. Errors are still there, any other way to do this?

VictoriaEagen gravatar image VictoriaEagen  ( 2015-11-02 14:49:51 -0500 )edit
1

You are trying to remove orphan base surfaces (that don't have spaces), the script you ran removes sub-surfaces that don't have a base surface. Looks like the diagnostic script doesn't look for orphan base surafces, but the measure described in my answer will. Load model into OS app to run measure then save and re-open in Plugin.

David Goldwasser gravatar image David Goldwasser  ( 2015-11-02 15:28:18 -0500 )edit

Gotcha. Sorry, new to the lingo, and no previous experience. I appreciate the help.

VictoriaEagen gravatar image VictoriaEagen  ( 2015-11-02 15:51:16 -0500 )edit

No problem happy to help. We need to really consolidate all of our diagnostics to one place. I think that will be the measure. That way it isn't dependent on SketchUp.

David Goldwasser gravatar image David Goldwasser  ( 2015-11-02 16:00:01 -0500 )edit
0

answered 2016-05-07 06:59:45 -0500

gaofeng gravatar image

I had met this situation before, you need redraw the you model, maybe there are some problems from your drawing method which conflicts with OS' s drawing language.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

3 followers

Stats

Asked: 2015-11-01 18:39:32 -0500

Seen: 1,444 times

Last updated: May 07 '16