Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
0

OpenStudio Application on Ubuntu 24.04

asked 2024-05-19 11:10:52 -0500

LucasL's avatar

Hi All,

I'm trying to install OpenStudio Application under Ubuntu 24.04. Current version 1.7.1 shows support for Ubuntu 22.04. When running the deb package I ran into dependency problems as stated here for a much older version. Applying the solution mentioned by Julien is not so feasible in this case as you run later into more dependencies problems.

I'm wondering if someone could please help me resolving those issues or, maybe we just need to wait for another compatible deb file on GitHub.

Thanks in advance for your time and comments.

Lucas

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2024-05-19 16:07:03 -0500

efrainpuerto's avatar

For installations in Ubuntu is better to stay a version before (Ubuntu 22.04 in this case), the default instalallations for OpenStudio are available in the Release Notes (https://github.com/openstudiocoalitio...). There is not support in this moment for 24.04 version, I suggest you change to Ubuntu 22.04, because you will have the same problem with other programs. I had the same problem two years ago installing the 22.04 version. Or, If you want to keep working with 24.04, create a Virtual Machine or a Docker for Ubuntu 22.04 in your machine and install it there.

edit flag offensive delete link more

Comments

Thanks for your reply Efrain! I agree. I upgraded from 22.04 to 24.04 but I think I'll have to find a way back to 22.04 or wait for a compatible .deb

Thanks again!

LucasL's avatar LucasL  ( 2024-05-20 09:02:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Careers

Question Tools

1 follower

Stats

Asked: 2024-05-19 11:10:52 -0500

Seen: 91 times

Last updated: May 19