Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

E+ Simulation runtime with transmittance schedule

asked 2023-10-30 09:13:04 -0500

Remi's avatar

updated 2023-10-30 11:06:50 -0500

Model created with DesignBuilder 7.0 / E+ version : 9.4

I assigned a transmittance schedule to shading surfaces (x7). I note that with a transmittance schedule, the calculation time becomes very long. The model is not very large (17 zones) and the initialization phase seems very long. Without trnasmittance, the simulation time is around 20 min. With transmittance, the initialization phase (before the simulation starts) is very long, so I stop the simulation because after more 2 hours, it doesn't seem right. Note that I have other opaque shading surfaces to take into account a dense urban context. I experienced the same thing with an other model with trees.

Is this normal? I'm looking for information on a possible software limitation on this subject of tranmittance in shading surface and how to remedy it. I can suppply a model to discuss around this problem.

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2023-11-06 16:13:08 -0500

Jamie Sullivan's avatar

A possible answer is that it's your shadow calculation algorithm.

I ran into this problem in the past when I tried to use the PixelCounting algorithm with scheduled shading (v22.1.0). If this is the case, you can fix it by switching to PolygonClipping.

Note that PixelCounting does not actually work with transparent shading at all, though it won't give you any indication of this below version 22.2 where a warning was added.

Also, if you can get it to work it may also be a good idea to run some QA checks on your results - I found that making my shading transparent in winter made the cooling lower than if the shading was opaque all year, which clearly isn't correct. The solar gains were being altered correctly, but the summer temperatures and cooling loads were off. This might have just been my model though, so I raise it mostly to suggest that it's something to check.

edit flag offensive delete link more

Comments

Thank you for your reply and tips. I use the PolygonClipping algorithm. The Sky diffuse modelling algorithm is set at Detailed sky diffuse modelling to take into account the transmittance variation of my object. Maybe it's this sky diifuse calculation method witch cause the lenght of simulation time. For the moment, the problem isn't resolved. I run 2 different simulations : one for winter and one for summer. It's to simulate projection blind.

Remi's avatar Remi  ( 2023-11-20 06:57:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Careers

Question Tools

1 follower

Stats

Asked: 2023-10-30 09:13:04 -0500

Seen: 120 times

Last updated: Nov 06 '23