Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question

openstudio epw file only have one day in dataviewer

asked 2023-07-18 22:09:04 -0500

just a undergraduated's avatar

updated 2023-07-24 22:03:56 -0500

I'm using energyplus 9.2 and openstudio2.9.0,tring to do a freefloat test。After I input the epw file, I found that the room temperature changes as shown in the figure below. The change of the external weather environment can only be displayed for one day. Can someone teach me why this is the case? ![image description]image description!image descriptionimage descriptionimage description

edit retag flag offensive close merge delete


@just a undergraduated can you try to attach your image again? It looks like it didn't come through correctly the first time.

Note that DView will have separate rows on the right of the tool to show OpenStudio results for a design day (heating/cooling load calculations over 24 hours) separately from the run period (usually an annual simulation) for any of your requested output variables.

Aaron Boranian's avatar Aaron Boranian  ( 2023-07-19 16:59:51 -0500 )edit

Sorry, it's my first time using this,now i post the picture again

just a undergraduated's avatar just a undergraduated  ( 2023-07-20 00:00:18 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2023-07-20 09:12:13 -0500

Output variables can be generated at different reporting frequencies. It looks like you have generated outdoor air drybulb temperatures at a monthly frequency (blue line), which is why there are less values to plot than the zone air temperature at an hourly frequency (orange line). See more discussion in another Unmet Hours post here.

If you didn't explicitly request monthly outdoor air drybulb output variables in the Output Variables tab of the OpenStudio application, then you are likely applying a measure to your simulation that is adding that.

edit flag offensive delete link more


Thank you Sir! however, after I change the setting as recommand in your link ,the simulation result did not change and now I note that I set the run period for one year ,but it only shows one week result. I'm new to openstudio. So I'm still trying to figure it out.

just a undergraduated's avatar just a undergraduated  ( 2023-07-21 01:07:24 -0500 )edit

@just a undergraduated Check your Settings tab (gear icon on the left, 4th from the bottom). It looks like you have set the Run Period to the first week of January.

Even though you have loaded an EPW weather file with a full year of data, you can run a simulation (run period) with a smaller subset or portion of the year.

Aaron Boranian's avatar Aaron Boranian  ( 2023-07-21 09:56:57 -0500 )edit

thank you sir! I solved this problem by saveing the osm file as another name.Simulation finally can ran as I set

just a undergraduated's avatar just a undergraduated  ( 2023-07-24 22:03:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops


Question Tools

1 follower


Asked: 2023-07-18 22:09:04 -0500

Seen: 104 times

Last updated: Jul 24 '23