Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
0

datapoint failure error in PAT

asked 2023-06-27 14:36:14 -0500

MaRe's avatar

updated 2023-06-28 07:25:41 -0500

I am running a PAT analysis and I get an error called “completed datapoint failure”. I have searched this error type in the previous posts, and I found in a post that it could be related to having a file name or path name with spaces in its name. I tried to apply this suggestion, but my PAT analysis is showing the same error. My PAT version is 3.6.0 since it is the last version available in the Openstudio download web. I appreciate if someone can help me about this issue. Regards, Edgar

edit retag flag offensive close merge delete

Comments

really need more information than that, but you can start by viewing the server in a webpage. from there you can download the datapoint information and look at the error files

BrianLBall's avatar BrianLBall  ( 2023-06-28 14:38:39 -0500 )edit

Thank Brian for your answer. I saw the server webpage and it says that there are 2 datapoint failure since I have a baseline and just one alternative. It says in the column "Action" the word "destroy". I couldn't find any error file in the web server. I also had a look in some files in the simulation directory in the "logs" files and opened the "mongo", and "rails" files but for me it is no clear that they explains any error, despite I saw "datapoint" word many times. I don't know where else to have a look. I appreciate if your can guide me a little bit more. Thank you.

MaRe's avatar MaRe  ( 2023-06-28 18:01:16 -0500 )edit

i would be looking for the datapoint simulation log and the energyplus .err file. Those are avail from a datapoint page and in the .zip file for the datapoint

BrianLBall's avatar BrianLBall  ( 2023-06-29 06:48:42 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2023-06-30 13:32:38 -0500

PAT 3.6.0 and 3.6.1 have an issue where they were packaged with the wrong version of EnergyPlus. 3.6.1-1 was just released to fix this.

here are some slides on PAT and there are some debugging tips and pointers near the end of the deck.

edit flag offensive delete link more

Comments

Thank Brian for your answer. I downloaded the PAT slides. It is a very good material for learning to use in a better way PAT.

MaRe's avatar MaRe  ( 2023-07-04 18:08:12 -0500 )edit

Hello Brian, thank you for your messages. I updated PAT to 3.6.1-1 and Openstudio to 1.6.0 (3.6.1) and created another PAT file but I still having the issue. I wasn't able to find the err file in the downloads of the datapoint web or in the PAT file in my computer

MaRe's avatar MaRe  ( 2023-07-14 12:44:10 -0500 )edit

what about the other log files in the datapoint zip?

BrianLBall's avatar BrianLBall  ( 2023-07-14 12:56:36 -0500 )edit

Hello Brian, I found a zip file called "seed zip file" in the local server, but it was empty. I also found in my desktop a log folder created when PAT run, these files are called: delayed_job, dj_server, dj_worker_1 to 3, local, mongo, and rails. I could find on them something to explain or say about an error. I tried with other PAT measure and I had the same datapoint error.

MaRe's avatar MaRe  ( 2023-07-14 20:04:38 -0500 )edit

navigate using the OSAF GUI (view server button from PAT), to the datapoint page for the failed datapoint.you do that by clicking on the datapoint from the analysis level page. from the datapoint page, there should be the sdp_log_file which is the simulate datapoint log. check there for ERROR.

BrianLBall's avatar BrianLBall  ( 2023-07-15 07:23:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Careers

Question Tools

1 follower

Stats

Asked: 2023-06-27 14:36:14 -0500

Seen: 207 times

Last updated: Jun 30 '23