Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

Unrecognized SketchUp 2015 install location

asked 2015-07-01 13:35:44 -0500

Branco's avatar

updated 2015-07-02 10:07:00 -0500

At the end of OpenStudio 1.7.0 setup, a message appears saying 'Unrecognized sketchup 2015 install location. The OpenStudio SketchUp Plug-in will not be installed'. I've installed SketchUp Make 2015 in the E:\SketchUp\SketchUp 2015 location and the OpenStudio 1.7.0 in the E:\OpenStudio 1.7.0 location. Both are x64 version There's no more available space in C: partition; and it is not recommended to install other programs there rather than the Operative System. I've tried to add an E:\SketchUp\SketchUp 2015 shortcut into the C:\Program Files location and reinstall. But it hasn't worked.

Is there a way to explain OpenStudio setup that SketchUp 2015 is installed in the E:\SketchUp\SketchUp 2015 location?

Thank you.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
5

answered 2015-07-02 09:43:10 -0500

updated 2015-07-02 12:31:16 -0500

You can manually copy the plugin files to SketchUp's plugin folder, and then just restart SketchUp.

When you install OpenStudio (even if you don't have SketchUp installed) we place a copy of the necessary plugins within the OpenStudio installation. Within the OpenStudio install location go to "Ruby/Plugins". The files you need to copy are the "OpenStudio.rb" file and the "OpenStudio" directory.

Alex's post on this thread describes where within the SketchUp install you need to copy the files to.

edit flag offensive delete link more

Comments

Thank you for your response. Once both programs are installed, copying all files from E:\OpenStudio 1.7.0\Ruby\Plugins to C:\ProgramData\SketchUp\SketchUp 2015\SketchUp\Plugins and then restarting SketchUp solves it! I've tried this after and also works: Once installed SketchUpMake2015 in the E:\SketchUp location, proceed to install SketchUpPro2015 trial version in the C:\Program Files location and the OpenStudio 1.7.0 in the E:\OpenStudio 1.7.0 location (it shows no error message). Open SketchUp and make sure the plug-in is there. Close everything and uninstall SketchUpPro2015 trial version.

Branco's avatar Branco  ( 2015-07-02 12:56:56 -0500 )edit

@David Goldwasser I tried to find the folder for Sketchup 2018, but I could not find corresponding folder you mentioned. Do you know which folder I should copy to in Sketcup 2018?

katsuya.obara's avatar katsuya.obara  ( 2018-01-18 02:09:52 -0500 )edit

@katsuya.obara On mac it is under "Macintosh HD > Library > Application Support > SketchUp 2018 > SketchUP > Plugins"

David Goldwasser's avatar David Goldwasser  ( 2018-10-03 12:13:44 -0500 )edit
0

answered 2019-10-31 11:32:49 -0500

rogerl62651's avatar

On Windows, add the OpenStudio plug-in files described above to the folder called "Shipped Extensions" in SketchUp Pro 2018. Worked for me. I now have Sketchup Pro 2018 with bot the Euclid extension and the OpenStudio extension.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Careers

Question Tools

Stats

Asked: 2015-07-01 13:35:44 -0500

Seen: 550 times

Last updated: Jul 02 '15