Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
3

EnergyPlus setting heat transfer algorithm for constructions - leads to fatal error

asked 2022-07-26 08:54:41 -0500

AGeissler's avatar

updated 2022-07-26 16:52:17 -0500

Hi there,

does anyone have experience in setting the heat transfer algorithm of selected constructions? According to the IO-Manual, I can set the global behaviour via

HeatBalanceAlgorithm, ConductionTransferFunction, 200; !- Algorithm, Surface Temperature Upper Limit {C}

and can then change this for selected constructions like this,

SurfaceProperty:HeatTransferAlgorithm:Construction, BO05Override, ConductionFiniteDifference, BO05; !- Name, Algorithm, Construction Name

Seems easy & straightforward. However, I then get a fatal error when trying to run the simulation telling me that "InitialInitHeatBalFiniteDiff: Found Material that is too thin and/or too highly conductive ..." which gives a material name that is not part of the construction addressed.

Any ideas welcome. Best Achim

OS: macOS; EnergyPlus, Version 22.1.0-43b09606e2

edit retag flag offensive close merge delete

Comments

Can you provide a link to your IDF via, e.g., Google Drive or Dropbox?

shorowit's avatar shorowit  ( 2022-07-26 17:11:23 -0500 )edit

Hi Scott, thanks for taking notice. The .idf should be downloadable from here for a few days: https://drive.switch.ch/index.php/s/Q.... Best, Achim

AGeissler's avatar AGeissler  ( 2022-07-27 03:06:53 -0500 )edit

I'm not an expert in this area but, having looked briefly at your file, I agree with you that the error message is either wrong or confusing. I suggest creating a new issue at https://github.com/NREL/EnergyPlus/is....

shorowit's avatar shorowit  ( 2022-07-27 09:50:24 -0500 )edit

Hi Scott, thanks again, finally I found time to re-compile the current version of E+ (there seemed to be some commits in the general area of my problem). Sadly, to no avail. So now I created a new issue (#9597) as you suggested. Let's see what happens. Best, Achim

AGeissler's avatar AGeissler  ( 2022-08-11 07:20:50 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2022-08-15 14:06:53 -0500

RKStrand's avatar

This is definitely a problem and is being worked on. When you selected the CondFD solution, that triggered an initialization routine specific for that solution technique. The problem occurred in part because you used regular materials for the air layer rather than Material:AirGap. The CondFD code was basically going through all constructions and even ones that were not using the CondFD solution. That included one that had your air layer in it and this caused a problem. If you had used the air gap input rather than the regular material input, it would have skipped this and you wouldn't have gotten an error message. So, that is a temporary work around--change your air layer definitions to Material:AirGap. The full fix is to skip constructions that are not used for CondFD and that is what is being worked on. Hope this helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

1 follower

Stats

Asked: 2022-07-26 08:54:41 -0500

Seen: 72 times

Last updated: Aug 15