Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

Dehumidification Not Working for DX Two Stage With Humidity Control

asked 2022-07-25 23:58:04 -0500

rktct999's avatar

updated 2022-07-26 08:27:42 -0500

I am running a simulation using DX Two Stage With Humidity Control with humidistats in the zones set for 50% RH and a maximum humidity SPM. Yet the RH seems to be free floating in the spaces? Can anyone please advise why the dehumidification may not be working? The link to the .idf can be found here: https://drive.google.com/file/d/1VCql...

image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-07-26 12:34:57 -0500

updated 2022-07-27 09:48:47 -0500

Check the CoilSystem:Cooling:DX object that's created in the idf referencing the two stage coil - it is missing the inputs 'Dehumidification Control Type' and 'Run on Latent Load' required to get the coil to control for humidity.

To get those inputs, you'll have to use an EnergyPlus measure, the relevant code for which I've included in this issue documenting the defect.

Edit: In the Measures tab of the OpenStudio Application, bottom right there is a button with a green plus sign to 'Create Measure from Template and Add to My Measures'. Click that, a window will pop up to 'Create New Measure'. Enter name, etc, and change the Measure Type dropdown to 'EnergyPlus Measure'. The rest is optional. Click 'Create Measure and Open for Editing'. A file explorer window will open with the measure folder. Open measure.rb in a text editor, and replace the template code (lines 46 - 85) with the code from here. Delete lines 28-32 (no longer needed). Save the file. In the app, find and drag the new measure from the right-hand library pane to the 'EnergyPlus Measures' drop area. Run your model and verify it's working.

edit flag offensive delete link more

Comments

Thanks Eric! I am admittedly a noob when it comes to utilizing measures.... I have had experience running them in OS but not creating them. I assume the code you posted is the .rb but it is asking for an .xml file as well. Not sure how to generate that. Can you please provide some guidance?

rktct999's avatar rktct999  ( 2022-07-26 21:00:23 -0500 )edit

See edit above.

Eric Ringold's avatar Eric Ringold  ( 2022-07-27 09:48:54 -0500 )edit

Thanks Eric. I appreciate the thorough walkthrough of the steps.

I hate to impose more but I am still getting an error when I run the measure. Would you could provide a review? (https://drive.google.com/file/d/1XTi4...)

rktct999's avatar rktct999  ( 2022-07-27 21:47:34 -0500 )edit

You created a ModelMeasure, not an EnergyPlus measure. A ModelMeasure operates on the openstudio model (it's passed into the run method as the variable model), whereas an EnergyPlus measure passes the idf (as workspace) into the run method. We want to operate on the idf, so you need it to be an EnergyPlus measure. Try again, selecting 'EnergyPlus Measure' in the Measure Type dropdown of the 'Create New Measure' window.

Eric Ringold's avatar Eric Ringold  ( 2022-07-27 21:55:26 -0500 )edit

Ah! Can't believe I missed that. The measure runs now

rktct999's avatar rktct999  ( 2022-07-27 23:11:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

1 follower

Stats

Asked: 2022-07-25 23:58:04 -0500

Seen: 143 times

Last updated: Jul 27