Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
2

Help regarding rendering and white surfaces

asked 2014-10-22 18:15:22 -0600

sheikh gravatar image

updated 2015-07-10 09:02:30 -0600

I am unable to change the model from "render by boundary condition" to "render by surface type". Why is that? Also when I open the model in OpenStudio SketchUp, one of the surfaces appears to be white. Can anyone explain?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2014-10-23 12:00:22 -0600

I have also experienced this issue and found the easiest way to avoid this is to never save the sketchup file and always work in OpenStudio or OpenStudio leagcy. Also make sure you are drawing in a zone, you can tell this by making sure you have a dotted line box where you are drawing (this is relevant for legacy but might still be the case in openstudio as well). A white surface is sure sign your model is going to crash at some point and a lot of the work you do after you have seen the surface could be lost. We always save multiple copies regularly so we can go back to an older version if something goes wrong like this. If I see a white surface I save under a different file name, make sure to say I don't want to save any sketchup entities, close the program, then reopen and see what I have lost.

edit flag offensive delete link more
3

answered 2014-10-23 03:02:43 -0600

Julian's advise is good. Linking to a SketchUp file can be problematic, so it is better to work with an OSM and and use the "Open OpenStudio Model" directly.

More generally whenever you see surfaces as white, or that don't show up in the "OpenStudio Inspector" when you selected, then the OpenStudio model is not properly synchronized with the active SketchUp model. This can also create issues changing render modes. I would follow these steps when this happens.

  1. Save your OSM file as a new name to avoid overwriting your original file that may not have any issues
  2. Quit and restart SketchUp (don't open the new file yet)
  3. Go to the "Plugins" menu and then under "OpenStudio User Scripts/Reports" look for "OSM Diagnostic Script"
  4. Now browse to the new file you saved in step 1. and click ok.
  5. There are two options for removing objects with errors or warnings. The defaults of "true" and "false" are fine, but if you have lost of tiny surfaces you want to remove then setting both to true may be good

At this point the script will run, and will open your ruby console. The script will report out results of some basic testing for problematic objects such as surfaces with out a parent space, or surfaces without 3 vertices, it will look for surfaces with duplicate geometry within the same surface group. If it finds any issues it will save a copy of your file with "diagnostic" at the end of the name, leaving your original file untouched. Now you can open the resulting model through the traditional method using the "Open OpenStudio Model" button.

Note: one thing the script doesn't currently do is remove orphan sub-surfaces. These can result if you deleted a base surface but somehow not the subsurface. There is a dedicated user script for this under "Add or Alter Model Elements" section of the user scripts/Remove Orphan SubSurfaces". This script is also good for files that won't even open in the plugin. That was what it was originally developed for.

edit flag offensive delete link more

Comments

thanks a lot david

sheikh gravatar imagesheikh ( 2014-10-23 18:06:59 -0600 )edit
2

answered 2014-10-22 18:33:13 -0600

updated 2014-10-22 19:37:12 -0600

When I start using OS and Sketch up I used to have the same problem and the solution that Matthew Larson give me was this one:

  1. Open an empty sketch up file
  2. Then using the Open Studio Tool bar use the "Open OpenStudio Model" icon
  3. Search your file and then select the .osm file

He explain me that you need to work on the .osm file or otherwise you are going to mix the surfaces, The sketch up ones (white surfaces) and the open studio ones (grey surfaces) and open studio wont work with the white ones.

And probably you can't change renders because of this issue

I hope it works for you :).

edit flag offensive delete link more

Comments

thanks a lot juliannino. I'll try it right now n let you know if I have any furthur problem. stay blessed :)

sheikh gravatar imagesheikh ( 2014-10-22 19:17:36 -0600 )edit

@Julian Nino I made a small change to your answer. Putting spaces after the number causes the markdown text processor recognize them as a list.

Neal Kruis gravatar imageNeal Kruis ( 2014-10-22 19:38:49 -0600 )edit

Thanks Neal I didn't notice it when I write it

Julian Nino gravatar imageJulian Nino ( 2014-10-22 19:43:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

 

Question Tools

2 followers

Stats

Asked: 2014-10-22 18:15:22 -0600

Seen: 1,410 times

Last updated: Feb 20 '15