HVAC cannot be turned OFF

asked 2021-12-28 01:48:44 -0600

halimgur gravatar image

updated 2021-12-28 11:16:27 -0600

I continue running one of the example files: AirflowWindowsAndBetweenGlassShades.idf. The simulation produces results only for the two design days specified in the IDF file because the file has no _SimulationControl_ object.

Now, I am trying to turn off the HVAC and do a simulation with no HVAC. I did the following to achieve this aim:

I added a new Schedule to the example file and called it AlwaysOff:

Schedule:Constant, AlwaysOff, Control Type, 0;

I then used this schedule as the Availability Schedule name for all HVAC equipment. There is only one type of HVAC used in this example file and it is ZoneHVAC:IdealLoadsAirSystem. There are one of these for each of the three zones. In the example file their availability schedule names (the second lines of each ZoneHVAC:IdealLoadsAirSystem record) were left blank, which implied that they were always available. I changed that to my new AlwaysOff. Here are the first three lines of the modified IdealLoadsAirSystem records. The other lines remain as they are:

ZoneHVAC:IdealLoadsAirSystem,
Zone1Air,                !- Name
AlwaysOff,                        !- Availability Schedule Name

I then ran the simulation as I did before. To my surprise and disappointment, the results were exactly the same as they were with the original file. The HVAC systems were called in during the design day simulations and they kept the temperatures in the set range.

I understand that I have conflicting information in the IDF file. I specify temperature set points for heating and cooling systems but set the availability of these heating and cooling systems to zero. I assumed that when a system were unavailable, its set points would be irrelevant.

Can anyone comment on why the unavailable HVAC systems are still called in to the job and why they work as if they were available?

edit retag flag offensive close merge delete

Comments

You could also try setting the heating capacity and cooling capacity to zero (along with their respective heating limit and cooling limit input fields to "LimitCapacity").

Aaron Boranian gravatar image Aaron Boranian  ( 2021-12-28 11:01:50 -0600 )edit

You could also try setting the heating and cooling availability schedules to "AlwaysOff", although the availability schedule you've already defined should be for the entire component.

Aaron Boranian gravatar image Aaron Boranian  ( 2021-12-28 11:03:16 -0600 )edit

Also, this may be related to an issue already logged on the EnergyPlus Github page concerning availability managers for other ZoneHVAC objects.

Aaron Boranian gravatar image Aaron Boranian  ( 2021-12-28 11:10:10 -0600 )edit

I thank you for the feedback. I understand that I could try other ways to turn zone HVAC off. I thought shutting off the connected unit would have been the easiest. It was disappointing that E+ Solver did not think so.

I checked the referred post on availability managers. Reading it convinced me further that it should be dangerous to rely on the E+ availability hierarchy to operate as expected. Thanks.

halimgur gravatar image halimgur  ( 2021-12-29 00:05:50 -0600 )edit

@halimgur are you able to share your IDF via Dropbox, Google Drive, etc.? That way others can review your inputs and determine if it's a user error or possible bug to report.

Aaron Boranian gravatar image Aaron Boranian  ( 2021-12-29 09:31:29 -0600 )edit