Question-and-Answer Resource for the Building Energy Modeling Community
Get started with the Help page
Ask Your Question
1

OpenStudio Crash Remove Thermal Zone Equipment

asked 2021-12-01 18:17:58 -0600

glinn07 gravatar image

updated 2021-12-02 11:27:18 -0600

Hi,

I'm having a lot of trouble changing out the HVAC system in this model. I am trying the replace the HVAC with an Appendix G baseline system.

-When I use a measure like Remove All Equipment (in the attached project folder), it runs and appears to work, but every time I go back to the Thermal Zone Tab it crashes

-When I try running a measure to add a new HVAC System on top of the old one (like the PSZ 4 in the attached project folder), it works but it leaves lots of old Zone equipment in place. When I start deleting zone equipment eventually one item crashes the model when I try to delete it. The offending item seems to be random.

Is there a better way to do this? I tried making a new OS model and importing data from the old OSM but that blows away both HVAC and schedules, constructions, etc.

Link to Zip of my project folder: https://drive.google.com/file/d/19hL5...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-12-02 11:08:53 -0600

glinn07 gravatar image

OK I figured it out

It seems I had one Zone Equipment List that was configured in a way that OpenStudio crashed when I tried to remove all of its equipment

Most of the Zone Equipment lists look like this I could delete equipment no problem:

  OS:ZoneHVAC:EquipmentList,
  {e2c212b0-56c5-430c-8da5-c6cf314a29fb}, !- Handle
  Zone HVAC Equipment List 12,            !- Name
  {1ef0ff99-b04b-4c84-8d77-2c4156a7c8c4}, !- Thermal Zone
  ,                                       !- Load Distribution Scheme
  {9562c4f7-a8e8-473b-a59b-9cd0981ea7e4}, !- Zone Equipment 1
  1,                                      !- Zone Equipment Cooling Sequence 1
  1,                                      !- Zone Equipment Heating or No-Load Sequence 1
  ,                                       !- Zone Equipment Sequential Cooling Fraction Schedule Name 1
  ;                                       !- Zone Equipment Sequential Heating Fraction Schedule Name 1

But one Zone Equipment List looked like this and every time I tried to remove all equipment it crashed OS:

OS:ZoneHVAC:EquipmentList,
  {cdef289f-8008-45a2-b91f-43b756826bf3}, !- Handle
  Zone HVAC Equipment List 7,             !- Name
  {15aae813-ea04-418d-88ed-5058e00c2071}, !- Thermal Zone
  ,                                       !- Load Distribution Scheme
  {0eaac6be-56ae-4113-9e10-22fd8600a119}, !- Zone Equipment 1
  1,                                      !- Zone Equipment Cooling Sequence 1
  1,                                      !- Zone Equipment Heating or No-Load Sequence 1
  ,                                       !- Zone Equipment Sequential Cooling Fraction Schedule Name 1
  ,                                       !- Zone Equipment Sequential Heating Fraction Schedule Name 1
  ,                                       !- Zone Equipment 2
  ,                                       !- Zone Equipment Cooling Sequence 2
  ,                                       !- Zone Equipment Heating or No-Load Sequence 2
  ,                                       !- Zone Equipment Sequential Cooling Fraction Schedule Name 2
  ;                                       !- Zone Equipment Sequential Heating Fraction Schedule Name 2

Anyone have an idea of why this would this happen?

edit flag offensive delete link more

Comments

It looks like there was a second zone equipment object at some point, and I assume was deleted. Those extra fields should have been removed as well. I think having those fields but not having a an object in "Zone Equipment 2" would probably cause a crash. Have you tried modifying (a copy) of the OSM file to remove all the fields for equipment 2. Make sure the last field for equipment 1 has ends with a ; and no ,

David Goldwasser gravatar image David Goldwasser  ( 2021-12-02 14:09:34 -0600 )edit

Thanks David. I did as you suggested and now it opens without crashing.

glinn07 gravatar image glinn07  ( 2021-12-02 15:35:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Training Workshops

Question Tools

1 follower

Stats

Asked: 2021-12-01 18:17:58 -0600

Seen: 104 times

Last updated: Dec 02 '21